SRCDS Steam group

"Adding master server" doesnt seem to run when starting up server.
Server OS: Debian 5 64-bit
Processor: Intel Core 2 Duo 3.0 Ghz
Ram: 8 GB.
Game: Team Fortress 2
Start Up Command: ./srcds_run -game tf -timeout 30 -autoupdate -debuglog tf2debug.log +map cp_dustbowl -port 27015 +maxplayers 24 -ip
Admin Mods: No Mods

Hi all, I have been going crazy over the past 2 days trying to figure out my problem and searching nonstop has lead me to find people with similar problems but no answer.

Following the most basic install procedure provided by this site and many other I have srcds for tf2 installed. All my ports are correctly forwarded. Me and a friend of mine are able to join my Server by directly going to the IP. And it shows up find that way. But I am never able to see it in the Master Server List.

And I notice unlike many other people here when my server starts up I never see the "Adding master server lines." I've seen suggestions from people saying to put setmasterserver xxx cvar into your server.cfg but every time its suggested, someone follows up saying you shouldn't have to or its not needed.

Which leads me to wonder if i am missing some file, or is something wrong which lead to my server never attemping to add itself to the master server?

Example of the end of my startup log.

sv_pure set to 1.
Note: Changes to sv_pure take effect when the next map is loaded.
exec banned_user.cfg: file size larger than 1 MB!
exec banned_ip.cfg: file size larger than 1 MB!
Writing cfg/banned_user.cfg.
Writing cfg/banned_ip.cfg.
Server logging enabled.
Server logging data to file logs/L0507005.log
L 05/07/2010 - 01:26:03: Log file started (file "logs/L0507005.log") (game "/home/steam/srcds/orangebox/tf") (version "4196")
Unknown command "mp_autoteambalance_delay"
Unknown command "mp_autoteambalance_warning_delay"
L 05/07/2010 - 01:26:03: server_cvar: "mp_teams_unbalance_limit" "3"
L 05/07/2010 - 01:26:03: server_cvar: "mp_stalemate_enable" "1"
L 05/07/2010 - 01:26:03: server_cvar: "mp_timelimit" "25"
L 05/07/2010 - 01:26:03: server_cvar: "decalfrequency" "30"
exec: couldn't exec cp_dustbowl.cfg
Connection to Steam servers successful.
   VAC secure mode is activated.

Normally when I see what others post, it usually includes:
Adding master server
Adding master server
before the "Conection to Steam" line.

Why does this not happen for me?

The server starts up fine and everything works except it can never be found through a search on the master server list and its driving me nuts. Any help would be appreciated.

It seems that there are a handful of servers experiencing this issue (including ours) - they can't automatically determine and set their master servers and if you set it to the domain name, it simply doesn't resolve properly.

The only way we've been able to resolve the issue is manually setting the master servers by IP address as mentioned here:

By all accounts this is Very Bad, and we shouldn't do it (nor should we have to do it), but for the moment, this has been the only way we can get our Orange Box servers listed.

I should mention that we're going to be keeping a close eye on these servers - should the master server IPs change, the servers will once again be unlisted (part of the reason it's not a recommended method).

Hope this helps - it's a frustrating issue.
Thank you so much. I thought I was the only one who had this particular problem. And I've been so frustrated, begin unsure at to what I could of done wrong or if it didn't download or install correctly. At least I can have solace in the fact that it isn't anything I'm doing wrong. And if you ever find out the real reason behind this please let me know, or post it here. I guess for now I'll have to set it manually. :-\

Thanks again!

Ah, this is always the way - the day after you find the fix, it gets properly addressed.

There was an optional update for Linux OrangeBox servers released today:

"Fixed an issue where Linux dedicated servers would not automatically retrieve master server addresses"

There you go. You can update your servers, remove the manual setmaster lines from your server.cfg and all should be well - we're updating our servers as I type this.

Until they do this again Rolleyes
Yep, Just saw that. And went on to Update. At first I was a little afraid because when starting up the server after the update, I still did not see a "adding master server" in the log. But I went ahead and checked and I am able to find it in the master server list. So all is well! :-D

With dods it isnt. I stoped the server removed the setmaster and updated. Starting it no master is set and the server is not at the serverlist.
So I roled back to the previous binarys
Strange. Both our DOD:S and TF2 servers are now showing without manually setting master servers.

Don't forget to check it again next time Valve release a non-optional update...

Forum Jump:

Users browsing this thread: 1 Guest(s)