SRCDS Steam group

Game ports
I have a problem and i just cant seem to find a solution to fix this.
My CS:S ports are always random 65978. 49277 etc, and -port +port -hostport +hostport 27015 doesnt seem to work. I am using win 7 and im using ubuntu 10.24 LTS as a guest using vmplayer.
Furthermore, I can see my server in the server list ( i switch to win 7 window to play cs:s ) but after about 1min of gameplay on my server crashes just freezes with connection problem.
Can anyone help? Maybe theres a solution ti this?
P.S. Im new to ubuntu or linux for that matter, so maybe m doing something wrong?
I guess you are using NAT somewhere. You cannot control the external port in that kind of scenario, unless you setup a port forwarding by hand.

btw: running game servers inside a VM is not a good idea. performance will be bad and you will have lags. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_gdr.100226-1909)
Language: Lithuanian (Regional Setting: Lithuanian)
System Manufacturer: To Be Filled By O.E.M.
System Model: To Be Filled By O.E.M.
BIOS: Default System BIOS
Processor: Pentium® Dual-Core CPU E5300 @ 2.60GHz (2 CPUs), ~2.6GHz
Memory: 4096MB RAM
Available OS Memory: 3264MB RAM
Page File: 1679MB used, 4844MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 64bit Unicode

My pc stats here . Plus I've got 40mb/s native and 20mb/s upload speed for abroad users. And yes - NAT is enabled in the vm option. Its the only way to have internet for both os.(atleast i dont know how to make them share the internet with other options).
I know it could lag but i still want to try atleast till i get my second pc this summer, so is there any way to add the port manually on ubuntu?
no, the problem is not with ubuntu. it's the NAT of vmware that assignes some arbitrary external port. try brigding instead, then the ubuntu will get its own IP in youre network. beware there could be another NAT involved in your router. you need to define a correct port fowarding there as well.

what do you want to achieve by running srcds inside the VM? why don't you use the windows version instead? that would be better in many aspects. (or even better: run ubuntu directly on the machine, not inside a VM) (Linux Kernel HOWTO!)
Do not ask technical questions via PM!

Forum Jump:

Users browsing this thread: 1 Guest(s)