SRCDS Steam group

Server configuration:

Phenom II 940 3.0Ghz, 8GB DDR2 800 RAM, 4x500GB RAID-10 SATA with a 1TB backup drive for the array.

CentOS 5 64bit with wine.

I'm running a Garrysmod server, and I get steam_id_pending for the first two minutes (it then goes away). It's not really groundbreaking, but it is annoying.

I keep hearing about how it might be a dl issue (wine lacking a system32 dl) if so, does anyone know the specific DL in question?.

I know your going to say use windows, but the problem for me is that I am using a software RAID and not a hardware. Now, I could emulate a hardware raid through BIOS for windows, but to be honest it would be a pain and it lacks the features the linux software raid has (mdadm).

And don't say not to use raid because I get the following with raid in terms of speed:

hdparm -tT /dev/md0

Timing cached reads:   11672 MB in  2.00 seconds = 5839.79 MB/sec
Timing buffered disk reads:  722 MB in  3.03 seconds = 238.63 MB/sec

238MB/s beats the 40-80MB/s I would get out of a single drive.

Anyway, yeah. Do you know how to solve this problem?. Thanks!.


Wine is also printing the following in its own window (not srcds):

fixme:netdll:NtLockFile I/O Completion on lock not implemented yet.
Er.. not sure if its permanently fixed, but for now it seems I solved the issue...

I don't know if it was that I set the IP and port in the command line or that I opened ports in the firewall (Which shouldn't have solved anything since my firewall was disabled and the issue happened before I re-enabled it).

Anyway, I opened the following in CSF:

Quote:TCP IN: 27015,27020,27021,27022,27023,27024,27025,27026,27027,27028,27029,27030,27031,27​032,27033,27034,27035,27036,27037,27038,27039
TCP OUT: 27015,27020,27021,27022,27023,27024,27025,27026,27027,27028,27029,27030,27031,27​032,27033,27034,27035,27036,27037,27038,27039
UDP IN: 1200,27000,27001,27002,27003,27004,27005,27006,27007,27008,27009,27010,27011,270​12,27013,27014,27015
UDP OUT: 1200,27000,27001,27002,27003,27004,27005,27006,27007,27008,27009,27010,27011,270​12,27013,27014,27015

Yes, I manually enabled each port instead of doing a port range...

Like I said, not sure if its fixed or if the valve master server somehow memorized my server IP. But I now no longer have steam_id_pending myself.
CSF is fantastic, but it can block you out if you screw up >_<

Forum Jump:

Users browsing this thread: 1 Guest(s)