SRCDS Steam group

Segmentation fault on steam update
Trying to update TF2 server but when I do I get

Checking bootstrapper version ...
Segmentation fault

So I ran it with gdb and get this

Program received signal SIGSEGV, Segmentation fault.
0x0025f9b4 in free () from /lib/

Should I re-install the lib? Will that fix it?
I am seeing this _exact_ same problem (Including the gdb diagnosis). Started at the same time as well (after the update on the 24th). I thus can't update my L4D server.

In-game, the "connect host:port" command tells me that the server uses an invalid protocol "received 1017, expected 1018" (or something just like that). I think this is a reference to the version numbers, which was 1017 and changed to 1018 on the 24th.

I've already tried deleting all data in the .steam folder. I have no idea what else to try, it's very frustrating. Any ideas? Have you figured anything out propaganda?
From Quintus's post, we can see that at least his is obviously caused by an update error. Try deleting '/lib/' and update. The other only suggestion I can give you is to completely wipe that install, or try to install it in another directory.

Good luck,

Forum Jump:

Users browsing this thread: 1 Guest(s)