SRCDS Steam group

rcon isnt working
Hey all, i have never had this problem with an SRCDS install before, and i cant figure it out myself so here it is.

Fresh install of debian 5.something linux with default kernel tf2 server wont accept an rcon log in from any where, wither it be from a client on the server HLSW or anything of the like, the only add on to the server is mani admin but i couldnt find anything any where where mani breaks rcon, the server when ssh'd into says the password is the same from the config, and the box is on the DMZ, its really anoying not being able to rcon cmd's to the server and having to log in, any ideas would be greatly appreciated.
Do you have +ip <ip-adress> in your startup line?
(02-23-2010, 06:50 AM)Arjen Wrote:  Do you have +ip <ip-adress> in your startup line?

no, should have that, mmk well ill test that,
(02-23-2010, 01:50 PM)Largo Usagi Wrote:  
(02-23-2010, 06:50 AM)Arjen Wrote:  Do you have +ip <ip-adress> in your startup line?

no, should have that, mmk well ill test that,

well tried that as well and it still refuses rcon, is the ip suposed to be the internal or the external, i chose to use the external and it didn't work. i dont forsee the logic behind declaring the LAN ip, but a link to the launch cmd's with what they are for/do would be very much apreciated

Thank you
Try "+ip". Then you can connect either LAN or external IP. However, I think you have firewall blocking the connection to the rcon port. You've ran srcds servers before so you probably know how to set HLSW and other settings correctly. Verify that you haven't accidentally blocked HLSW in your firewall.
I have one Linux box behind a router.
In the startupline: +ip <local ip> -port 27015
In server.cfg: rcon_password "<pwd you prefer>"
On your router open ports (27000 to 27015- UDP, 27030 to 27039- TCP, 1200- UDP, 27020- UDP, 27015- TCP) to the local IP (or enable DMZ to start).
That should work.
I think we could use some more information:
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
the box is DMZ'ed it might as well be a gaping hole on the internet and yet it still doesnt allow rcon, i think it may be the lynksys routers firewall being fucking fail, so im going to try installing DD-WRT on it and see if that fixes the problem, the servers i ran before wouldnt even forward on some linksys routers, so ill try that, here is the startup script

echo "Starting TF2 Server"
sleep 1
screen -A -m -d -S tf2 taskset -c 1 ./srcds_run -console -game tf -autoupdate -ticrate 67 -ip -port 27015 +map ctf_2fort +maxplayers 24 +fps_max

if there is anything else you would like to know please ask, im obviously missing the relevant information that is causing the problem.

oh i just saw this warning when i rebooted the box
WARNING: NNET_OpenSocket: bind: Cannot assign requested address
SOLVED, when i changed the ip to bind on rcon started working, thanks for the help, but that is an odd error to me, if some one wants to lock this thread that would be great.

Forum Jump:

Users browsing this thread: 1 Guest(s)