SRCDS Steam group

Strange connection and sound problems with TF2 servers
Since early Monday of this week (2/15/2010) all four of my TF2 servers have been having major issues. It is nothing I have been able to pinpoint yet, as there has been no changes to any of them with the exception of running the game updates from Valve. What has been happening is that when there's more than about 10 clients in a given server everyone's mic begins to cut out sporadically. When a given server gets up to around 20 clients, then everyone's mic is unintelligible and people start having issues connecting. The strange part of it is that the servers otherwise seem fine. Movement is smooth, everyone's ping is stable, etc. It's just the sound and initial connection issues that have been plaguing them.

I haven't seen anybody but myself report these issues on the HLDS mailing list, nor have any of the other Linux servers I've visited had any of them. I am assuming this is a problem specific to my setup, so I am posting here for guidance.

I've had these servers set up the same way for months without any problems until the start of this week. And again, nothing was changed around the point they started doing this. They all just started doing it out of the blue Monday morning.

I've tried restarting them, removing plug-ins, and doing a complete replacement of the game engine files. Doing all these has not solved the problem.

Looking at processes running, there is nothing gobbling up the CPU or network resources on the machine. Is this possibly an issue related to my provider (this is a machine located in a data-center)? Has anybody else been experiencing this?

Server OS: CentOS 5.4 64-bit
Processor: "Unknown" Pentium quad core, 2.65GHz
Ram: 8GB
Game: Team Fortress 2
Start Up Command:
echo "Starting TF2 Server #1"
sleep 1
cd /gameservers/tf2-server-1/orangebox/
screen -A -m -d -S tf2-server-1 ./srcds_run -console -ip -port $PORT -game tf +fps_max 400 +map arena_badlands +maxplayers 32 $1

sleep 1
pid=`ps ax | grep /srcds_ | grep -v SCREEN | grep -v grep | grep -v /bin/sh | grep $PORT |  awk "{print \\\$1}";`
#echo pid is $pid

sudo renice $PRIORITY $pid > /dev/null
taskset -cp $AFFINITY $pid > /dev/null

Admin Mods: MetaMod 1.8.0 and SourceMod 1.3.0

The command I used to try updating it today as a trouble-shooting step. It caught two game engine files that were out of date, but still did not solve the issue.
./steam -command update -game tf -dir ./tf2-server-1 -verify_all
is iptables running on the system? Sometimes if iptables isn't configured it reacts weirdly with srcds. Also, I assume when all of this starts to happen load on the machine is normal and at an acceptable level?

Forum Jump:

Users browsing this thread: 1 Guest(s)