SRCDS Steam group

No one can connect to my server
Server OS: Windows XP 32-bit
Processor: AMD Athlon 64 X2 Dual
Ram: 2gb
Game(s): Garry's Mod
srcds.exe Wrote:241.7 fps 0/ 5 on map gm_flatgrass
Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game.dll loaded for "Garry's Mod"
Mounting hl2.. OK
Mounting ep2.. Failed
Mounting tf.. OK
Mounting cstrike.. OK
Mounting dod.. OK
Mounting episodic.. Failed
Mounting hl2mp.. OK
Mounting portal.. Failed
Mounting lostcoast.. Failed
Mounting hl1.. Failed
Mounting hl1mp.. Failed
Mounting zeno_clash.. Failed
Error, bad server command sv_allow_voice_from_file 0
Parent cvar in server.dll not allowed (sk_apc_missile_damage)
Garry's Mod client.dll Build #072 [Nov 20 2009 20:20:42]
maxplayers set to 5
Unknown command "cl_interp"
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Unknown command "sv_rollangle"
Unknown command "sv_unlag_fixstuck"
Lua initialized (Lua 5.1)
======== Installing Table (De)Serialiser Module | ver: 1.4 ========
=== Wire 2035 Installed ===
======== Beam NetVars Lib v0.71 Installed ========
ERROR! Module 'zlib_b64' not found!
==== Advanced Duplicator v.1.72 shared module installed! ====
Added EntCheckHook: AdvDupe_NoItems
Added EntCheckHook: AdvDupe_DisallowedClasses
Added EntCheckHook: AdvDupe_ModelCheck
==== Advanced Duplicator v.1.85 server module installed! ====
Registering gamemode 'sandbox' derived from 'base'
ScriptEnforce is disabled
Loading Wire Tools
ASS Plugin -> plugins/ass_armor.lua
ASS Plugin -> plugins/ass_burn.lua
ASS Plugin -> plugins/ass_cleardecals.lua
ASS Plugin -> plugins/ass_exformat.lua
ASS Plugin -> plugins/ass_explode.lua
ASS Plugin -> plugins/ass_freeze.lua
ASS Plugin -> plugins/ass_gimp.lua
ASS Plugin -> plugins/ass_god.lua
ASS Plugin -> plugins/ass_health.lua
ASS Plugin -> plugins/ass_kill.lua
ASS Plugin -> plugins/ass_map.lua
ASS Plugin -> plugins/ass_mute.lua
ASS Plugin -> plugins/ass_noclip.lua
ASS Plugin -> plugins/ass_notice.lua
ASS Plugin -> plugins/ass_pickupplayers.lua
ASS Plugin -> plugins/ass_ragdoll.lua
ASS Plugin -> plugins/ass_rocket.lua
ASS Plugin -> plugins/ass_sandbox_cleanup.lua
ASS Plugin -> plugins/ass_sandbox_limits.lua
ASS Plugin -> plugins/ass_sandbox_options.lua
ASS Plugin -> plugins/ass_sandbox_propprotect.lua
ASS Plugin -> plugins/ass_sandbox_spamprotect.lua
ASS Plugin -> plugins/ass_sandbox_toollimit.lua
ASS Plugin -> plugins/ass_slap.lua
ASS Plugin -> plugins/ass_speed.lua
ASS Plugin -> plugins/ass_stopsounds.lua
ASS Plugin -> plugins/ass_team.lua
ASS Plugin -> plugins/ass_teleport.lua
ASS Plugin -> plugins/ass_voicemute.lua
ASS Plugin -> plugins/ass_weapons.lua
Executing dedicated server config file
ServiceStart: started as local thread
Server logging enabled.
Server logging data to file logs\L0118005.log
L 01/18/2010 - 17:20:27: Log file started (file "logs\L0118005.log") (game "C:\s
rcds\orangebox\garrysmod") (version "3943")
Adding master server
Adding master server
Connection to Steam servers successful.
VAC secure mode is activated.

I set up a dedicated server for Garry's Mod. It appears in the Internet tab for server listings. When anyone tries to connect it just sits at "Parsing Game Info" forever. However, when I connect to it via the LAN tab it actually works. What could the problem be?
Have the people be patient when connecting. It takes time. Just the fact they can get to Parsing game info means that they can see your server.
I tried it on my laptop. I sat there until it timed out.

My friend said he failed to connect. He didn't even get to the Parsing Game Info part.
He also said he was looking at Game Info, and it says Server Not Responding
Is he connecting via your external IP?
Yes he is

I've been looking around this forum and facepunch, and I've noticed a billion people with a similar issue (not always exactly the same, but similar). Not once did I find a solution...
I read this somewhere:

Quote:There's a bug in srcds which makes it unable to resolve your external IP (the IP people connect with) effectively making any server hosted behind a router a LAN-only game. There's no fix for it that I'm aware of, and I've tried a lot of things myself.

Is this accurate?

It's also been suggested that I use Hamachi (VPN) to fix this problem. Is this a good idea?
Running a game server on your personal computer isn't a good idea to begin with...
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
It's the only option I have at the moment.

I'd really like to get this to work... if not, I might have to rent a server or something. But that's absolutely last resort.
Honestly renting a game server shouldn't be a last resort as most game servers that are hosted at home don't perform well and nobody plays them.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!

Forum Jump:

Users browsing this thread: 1 Guest(s)