SRCDS Steam group

Failed to load Steam ServiceServiceStart error
I have been running a tf2 server now for a while, but just recently i have been getting the following error.

Failed to load Steam ServiceServiceStart: failed to start

I don't have steam installed on the system, and i know steam has a service that it installs and uses. i don't know why the dedicated server though would want to use it. And i have had the server running before, and it has never wanted this. any help would be great. thank Smile
What is your startup line, your servers hardware / software specs?

There is a readme... Please read it.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
[Image: srcds-read-me.jpg]
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
i have this problem too... Sad

Server OS: windows 2003 sp1
Processor: Intel Pentium 4 2,6Ghz
Ram: 2 GB
Game(s): TF2
Start Up Command: srcds.exe -console -game tf +maxplayers 24 +map ctf_2fort
Admin Mods: MMS/SM

start server:
Console initialized.
Game.dll loaded for "Team Fortress"
Particles: Missing 'particles/error.pcf'
maxplayers set to 24
Unknown command "r_decal_cullsize"
maxplayers set to 24
Network: IP x.x.x.x, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
[TS] Hooking round end events for game: tf
Executing dedicated server config file
[TS] Team Names: Red Blue - OnRoundEnd available: yes
Failed to load Steam ServiceServiceStart: failed to startExecuting server.cfg
sv_pure set to 2.
Note: Changes to sv_pure take effect when the next map is loaded.

Failed to load Steam ServiceServiceStart: failed to start in console and in orangebox\logs created 2 files:

[2009-12-23 21:54:33][0,0] : Log session started
[2009-12-23 21:54:33][0,0] : SetSteamID( [A:1:0:0] )
[2009-12-23 21:54:33][1,2] : Connect() starting connection (eNetQOSLevelLow,, UDP)
[2009-12-23 21:54:34][1,2] : ConnectionCompleted() (, UDP)
[2009-12-23 21:54:35][1,2] : RecvMsgClientLogOnResponse() : 'OK'
[2009-12-23 21:56:00][3,0] : Log session ended

[2009-12-23 22:01:48][0,0] : Log session started
[2009-12-23 22:01:48][0,0] : SetSteamID( [A:1:0:0] )
[2009-12-23 22:01:48][1,2] : Connect() starting connection (eNetQOSLevelLow,, UDP)
[2009-12-23 22:01:49][1,2] : ConnectionCompleted() (, UDP)
[2009-12-23 22:01:49][1,2] : RecvMsgClientLogOnResponse() : 'OK'

12/23/09 22:01:47 : Failed to load Steam Service (3)
12/23/09 22:01:47 : ServiceStart: failed to start (0)
Some Problem here as Aizek with my new gmod server.
Did you guys give up? Or please say how this got solved - desperate to get this solved
Ok it seems that the error message doesn't actually matter. Just make sure you have the ports forwarded correctly, and try turning off firewall. Then also in your server.cfg, add "ip" with your INTERNAL ip address, then "hostport 27015". Suddenly everything worked for me after that, and make sure not to have any IP or PORT in your HLDS shortcut.
I have gotten the same thing, but it says on the bottom
'server.cfg' no present; not executing.

Forum Jump:

Users browsing this thread: 1 Guest(s)