SRCDS Steam group

Can't install steam files... HELP!
Hello everyone, I'm a little new to Linux, but I love counterstrike and want to start up a cs source server for here in the dorms. Here is my info starting off:


GCC: gcc (GCC) 3.3.5-20050130 (Gentoo Linux, ssp-, pie-
Copyright © 2003 Free Software Foundation, Inc.

KERNEL: Linux Mike 2.6.11-gentoo-r6 #3 SMP Thu Apr 21 02:20:14 GMT 2005 i686 Intel® Pentium® 4 Mobile CPU 1.60GHz GenuineIntel GNU/Linux.........
I also have 628mb ram

NOW to what the error I get:

./steam -command update -game "counter-strike source" -dir /home/srcds_l
Checking bootstrapper version ...
Getting version 14 of Steam HLDS Update Tool
Downloading. . . . . . . . . . . .
Steam Linux Client updated, please retry the command

Can anyone help? Thanks

Hi silvershotm1,

Thats saysing its updated the tool now re-run the command. Just re-run the command and it will work.

and to launch the cs source server type something like

./srcds_run -tickrate 33 -game cstrike +map de_dust +maxplayers 18

from the srcds directory
Well, I run it for the second time and it displays this and nothing else

./steam -command update -game "counter-strike source" -dir /home/srcds_l
Checking bootstrapper version ...
Updating Installation
Receive Failure

It pauses for about 3-5 minutes before it shows the receive failure
/steam -command update -game "counter-strike source" -dir .

you have to add a "space" . after the dir
Well, I did that and it came to the same error with "Receive Failure". It doesn't seem to be downloading anything and getting very frustrating. Thanks for all the help.
What's really strange too is that when I login to steam on my windows computer, it tells me that my ticket id has expired and I need to retype the password. So I know something is going on with the network from my linux box, but just doesn't follow through.
sounds like its running off a router...
I'm here in a dorm environment. I guess the router then would be blocking steam? I pretty much just want to create a LAN environment and be able to play on my windows machine w/ other people here in the dorm. Possibly going to a friends house to download the files that doesn't have a router?

if its edu, then chances are, its blocked. should be studying, not fragging Wink
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
yea, most schools ive been to you have to use your own switch or something, wireless makes life very easy though Smile.

if you want to outsmart your server, try running your server on port 25 (smtp port), they will never catch it probably!
Sorry for reviving an old, dead thread, but I would like to post to say that I have the exact same problem with my server, save one very interesting issue:

The machine I want to run it on is a dual boot. The issue is: my server runs and works perfectly under windows, but not linux! I'm not sure if this extra bit of information would help anyone in figuring out the issue, but I'm stumped and have been for a good six months on this.

Here's some info:

uname -a
Linux hostname 2.6.12-1-k7 #1 Tue Sep 27 13:22:07 JST 2005 i686 GNU/Linux

Running Debian testing. Any other information can be provided.

Forum Jump:

Users browsing this thread: 1 Guest(s)