SRCDS Steam group

Debian Server
Hey Guys,

I have a really odd problem i wonder if anyone can advise me on this. Basically i have a dell 2.8ghz with 1gb of ram and a 100 meg full duplex connection on the server, the connection from that is fibre.

I try and download the srcds via the linux steam command ./steam etc and it downloads really slow.

One file would take about 5 minutes to download. If I try and download say one disc of the lastest debian release using wget its speed is roughly 600kbps plus.

I also have another server which is FC3 where when i run the steam command its as quick as lighting downloading the files.

Also when i type rcon quit to restart the server it takes at least 10 minutes plus to come backup again.

Its not the servers connection I have tried everything really, just thought I can't be the only one who has had this problem out there.

Some information about the box below:

Debian 3.1
Kernel: 2.6.8-2-386


ya thats weird man, i have been thinking on it a bit and the only idea i can come upwith is that you have some ports blocked with iptables or some such thing

Thanks for your reply. No ports blocked or any firewall. I kind of figured that nobody would know what it would be, oh well it was worth a post.


Hi. Im having the same problem. I have tried installing it on both Ubuntu and Fedora Core 4. Im having the same problem on both distros.. the download speed is horrible..

Is there some switch to tell the installer what content servers to use.. or is it just picking a random content server ?

In the windows version you have to choose what region you are in. Would there by any chance be an option like that for the linux version...?
Today i manged to get it running.. i had to disable SELinux and the firewall.. but i think SELinux was the only real problem..
Hi Guys,

Interesting I just decided to check back to the forums and see what has being happening etc. Yeah it is an annoying problem but all the same if you have had the same problem its not only me then.

The thing is right is that its debian with no firewal or selinux because thats for fedora etc.


Try to change your MTU to lower value, that is
ifconfig eth0 mtu 500

with eth0 being your device name Wink
gimme feedback, or else ;P


Forum Jump:

Users browsing this thread: 1 Guest(s)