SRCDS Steam group

L4D2 Dedicated issue
Hello! I've successfully created my own L4D2 dedicated servers with srcds. My server was even full for a couple of minutes and i could see it in the internet servers tab. I managed this using this settings: -console -game left4dead2 +hostport 27016 -clientport 27006 -nohltv +exec server.cfg +map c5m1_waterfront +hostip +sv_lan 0
Now when i want to connect to it, i get STEAM validation rejected. I tried using the same launch options as above, with this -ip, my lan ip. Now, using that option i cant establish connection with steam servers, as the console says. I dont have a router, my firewall is off, im using ESET antivirus and it's configured properly so all ports should work fine.
So why i cant connect to my server when sv_lan is set to 0? Oh and if you're asking, im trying this because i want to test all my plug-ins that i want to use on my server and since my computer is broke, i cant connect from anywhere else.

I hope you read this, and thanks for your help in advance
Hi here is the startup command line I use

-console -game left4dead2 +hostip x.x.x.x -ip x.x.x.x +hostport 27015 +clientport 27006 -nohltv +exec server.cfg +map c5m1_waterfront

hostip is your external IP and ip is your computers internal IP, I use both. I put the sv_lan 0 command in my server.cfg file not in startup commands. I assume you have created a server.cfg file and placed it in the CFG subfolder. Here is a copy of my server.cfg file.
Be sure the hostport in server.cfg & the hostport in startup commands match. I hope I helped.

hostname "your server name"
rcon_password "your remote console password"
sv_contact "your email address"
hostport 27015
sv_lan 0 // enable LAN = 1; disable LAN = 0
sv_region 0 // region 0 is east coast USA/region 255 is worldwide
sv_allow_lobby_connect_only 0 //enable/disable Lobby connections 1/0
sv_allow_wait_command 0
sv_alltalk 0
sv_alternateticks 0
sv_clearhinthistory 0

sv_consistency 1
sv_pausable 0
sv_voiceenable 1
sv_cheats 0
sv_forcepreload 1
sv_pure_kick_clients 0
setmaster add // for setti masterserver
exec banned_user.cfg
exec banned_ip.cfg

sv_log_onefile 0
sv_logbans 1
sv_logecho 1
sv_logfile 1
sv_logflush 0
sv_logsdir logs

sv_minrate 30000
sv_maxrate 60000
sv_mincmdrate 66
sv_maxcmdrate 101
For christ sake, dont use even the +hostip or +hostport arguments. They are OUTDATED and have been replaced by -ip and -port.

Use -port if you have more servers on the machine
Use -ip if you have configured multiple NIC's or IP-addresses
Dont use -clientport. Its useless
SourceTV isn't possible for L4D2 so no reason for using -nohltv argument

try to forward ex. port 27017 in your FW and put this in your startup line:
-sport 27017
Slå den med jeres fiberforbindelser...

[Image: 1308107839.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)