SRCDS Steam group

[resolved] segmentation fault
I'm attempting to run a TF2 server, and I'm getting a segmentation fault whenever an environmental death occurs on the server. I get a segmentation fault related to tf2's core file and the server resets.

Server OS: Ubuntu 9.10 32-bit
Processor: Intel Core2 Duo 2.4GHz
Game: Team Fortress 2
Startup command: ./srcds_run -console -game tf +maxplayers 24 +map achievement_idle_knii_4b -debug
Admin Mods: none

Terminal output when a player dies:
L 11/15/2009 - 02:25:22: "Picnic Basket<2><STEAM_0:1:25278809><Blue>" committed suicide with "world" (attacker_position "-481 120 64")
Segmentation fault (core dumped)
BFD: Warning: /home/tf2srvr/orangebox/core is truncated: expected core file size >= 208977920, found: 1040384.
Failed to read a valid object file image from memory.
Cannot access memory at address 0xbf133044
/home/tf2srvr/orangebox/debug.cmds:5: Error in sourced command file:
No function contains program counter for selected frame.
email debug.log to
Sun Nov 15 02:25:29 EST 2009: Server restart in 10 seconds

And from debug.log:
CRASH: Sun Nov 15 02:25:29 EST 2009
Start Line: ./srcds_i486 -console -game tf +maxplayers 24 +map achievement_idle_knii_4b -debug
[New Thread 5044]
[New Thread 5043]
Core was generated by `./srcds_i486 -console -game tf +maxplayers 24 +map achievement_idle_knii_4b -de'.
Program terminated with signal 11, Segmentation fault.
#0  0x001a3379 in ?? ()
#0  0x001a3379 in ?? ()
No symbol table info available.
eax            0x2773a0    2585504
ecx            0xdd8708    14518024
edx            0x20    32
ebx            0x275ff4    2580468
esp            0xbf132fdc    0xbf132fdc
ebp            0xbf133040    0xbf133040
esi            0x2773a0    2585504
edi            0x1    1
eip            0x1a3379    0x1a3379
eflags         0x10292    [ AF SF IF RF ]
cs             0x73    115
ss             0x7b    123
ds             0x7b    123
es             0x7b    123
fs             0x0    0
gs             0x33    51
From        To          Syms Read   Shared Object Library
0x002b5830  0x002cb69f  Yes (*)     /lib/
(*): Shared library is missing debugging information.
End of Source crash report

My assumption for this is that something is wrong with my core file but when I attempt to update, it doesn't give me anything new.
Have you tried deleting the InstallRecord.blob and after it updating with the -verify_all parameter?
Apparently I hadn't done enough testing before posting this thread.

The problem is in the map, not srcds.

(11-15-2009, 06:34 PM)Terrorkarotte Wrote:  Have you tried deleting the InstallRecord.blob and after it updating with the -verify_all parameter?

The map I was using doesn't have any observation points, so when you're alone on it and die, the seg fault occurs. On official maps and maps with observation points, it works fine.

Forum Jump:

Users browsing this thread: 1 Guest(s)