SRCDS Steam group

Problem's starting hl2mp & cstrike a Little help Please
Hello to all of the srcds community Big Grin

Ill start with the server spec as iv read the read me (im a good boy me Toungue)

OS: ClarkConnect (based on CentOS 5)
CPU: Intel® Pentium® Dual CPU E2220 @ 2.40GHz
HD: SATA 2 Seagate ES.2 1TB *2
Sorry but this is all i have on my hardware right now. All i can tell you is it's gigabyte mainbord (when im home ill look it up and change the post).

GCC: 4.1.2
ldd: 2.5
Kernal: 2.6.18-128.2.16.v5 (SMP)

Right the problem. When i try to start hl2mp or cstrike using
./srcds_run -console -game hl2mp +map dm_lockdown +maxplayers 16
i get this error
Unable to load interface VEngineCvar003 from bin/
(im not running any mod's... yet)
in the past iv had no problem getting these to run on this system!

Now after googling this error i found a cuple of post's here . But none of them seem to have a propper soluton or reson for this error. I have tryed all that is suggested but have had no joy.

If any one could give me the answer or point me in the right direction that would be grate

Thanks in advance
"-console" <<< del this .... its only important for a client not for server

try this at first >

./srcds_run -game hl2mp -autoupdate

when the files are ok should the parameter

./srcds_run -console -game hl2mp +map dm_lockdown +maxplayers 16

Thanks for the reply, was beginning to think there was somthing wrong with my post.

None the less iv tryed what you suggested and still no joy Sad

[duncan@server srcds]$ ./srcds_run -console -game hl2mp +map dm_lockdown +maxplayers 16
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.
AppFramework : Unable to load module bin/!
Unable to load interface VEngineCvar003 from bin/engine_i686.soWed Nov 11 21:29:57 GMT 2009: Server Quit

Begining to think i might have to give up on hl2mp and cstrike
Hi, check if the file bin/ exist !

If (or not) exist, try to update the server using ./steam ... (more help on
(11-12-2009, 08:12 AM)Thunderboy Wrote:  Hi, check if the file bin/ exist !

If (or not) exist, try to update the server using ./steam ... (more help on

its there, tryed deleting it then -update to replce it. Still no joy.
Its a fresh intsall any how. But thanks for the imput Shy
start the update with ./steam ..... -verify_all hopefully there is a damage file.
Sorry not been back in a while, thanks for all your reply's

After learning how todo other things in linux iv since re-loaded my server and now all works fine

Thanks for all your time Cool

Forum Jump:

Users browsing this thread: 1 Guest(s)