SRCDS Steam group

Unable to bind specific ports
Server OS: Windows Server 2003 R2 64-bit
Processor: Intel Pentium Core2Quad Q6600 2.4Ghz
Ram: 4GB
Game: Team Fortress 2
Start Up Command:
start srcds.exe -console -game tf -hostport 27021 +fps_max 600 +clientport 26911 +tv_port 27131 –steamport 26961 +map cp_granary +maxplayers 16 script, show the full command line used to start the server.
Admin Mods: SourceMod, MetaMod

For some unknown reason, it works on 3 of the other servers.

I just noticed after I start up my 3 servers, the 4th server is automatically binded to port 27023 and follows by 27024 if i start another server after. The other 3 that I have are correctly assigned with their ports 27016, 27017 and 27021.
Why are you setting –steamport?
~ trewq
got it from a guide long ago and i can't remember why.
The only nessecary parameter is "-port", which actually in most cases ain't needed.
Remove -hostport and +clientport and use -port
SBT is correct.
(my 2 cents)

Also, "guides from long ago" are generally old and don't have current information. Lot of people still use server.cfgs and bootup lines that are full of old and unneeded commands.
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.

Forum Jump:

Users browsing this thread: 1 Guest(s)