SRCDS Steam group

STEAM_ID_PENDING issue through Wine...
Hi guys,

I'm currently trying to get a source mod, 'Stargate: The Last Stand' to work through Wine (as some custom Sourcemod plugins do not work AT ALL with native Linux). It runs fine. I can connect - so there's no problems there. The problem I AM having though, is every single client's STEAMID doesn't load, and appears as 'STEAM_ID_PENDING' for as long as they connect.

This is a real pain - for all the obvious reasons (no admin to certain players, custom stats plugin will not work - you aren't even allowed to type anything in chat...).

Things I HAVE tried with no luck was:
- Adding +ip <server IP> to start up line, and
- Adding +port 27015 to start up line.

The strange thing is, we have a Garrys Mod server on the same box running fine under Wine, with no problems at all. So I'm starting to think it could be an issue with the mod itself - thought I'd ask here first though.

If you need any other info please ask! I'd really love to get this sorted out Smile.

Ben (-JR- Apophis).
Linux + Wine is more unstable that just Windows...

But yes, it sounds like its the mod itself, probably would rather run under a Windows OS then an emulated one.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
Yep... we had it running under a Windows VM before, but for some reason the resources were being hogged by SRCDS (spiked up to 70-80% CPU most of the time).
Virtual Servers suck...
If you would like a windows dedicated let me know.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
Nah probably not mate. Got a real good deal at the moment on this current server...

I'll have a chat to the main server admin later and see what he thinks of it all.
Alright, update.

Left the thing for a while... came back about 30-45 minutes later, and the 'VAC Secure mode enabled...' message had appeared in the server console window.

Opened the game, tested it out, no more 'STEAM_ID_PENDING'. So now, what would be causing it to take 30 bloody minutes to activate...?
try running only this single server, without other srcds in parallel. maybe it's some port blocking problem (then you might need to change the port more far away from the other server(s)). (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
Tried that... no luck!

But never mind. We're just going to run this one server in a Windows VM. Should work fine (as it's the only thing running).
Ok... well now it's doing it on both GMOD servers we are trying to run...

And another update...

It works fine when 'VAC secure mode enabled' message FINALLY appears after 10-15 minutes. I tried a 'heartbeat', did nothing.

Any ideas? I'm stumped.
One more for good luck - it's not just GMOD either, anything else running in Wine will have the same issue. Oh well, I'll just have to deal with it Toungue.
Bump... Toungue

Guess noone really has an answer?
Don't use wine to run servers

Forum Jump:

Users browsing this thread: 1 Guest(s)