SRCDS Steam group

fps problem for TF2 server
Hey guys new to the forum and dedicated servers.
Straight to it last night i was running a TF2 server with 1000fps no problems. Its a small 16 player server for my Clan. We had no issues with it everyone connected to it at about 50-90ping which i thought was amazing considering im currently running my net connection off of DSL hardware and not ADSL2+ (Still in the mail).
Anyway ive just started it back up and ive noticed it seems to be capped at 64.1fps and wont budge. I was messing around with my cfg to tweak the cvar settings to make the server a 66 tick but i think ive messed up somewhere..
But when i connect to the sever i see the fps jump right up to 1000fps but if someone else joins by them-self it stays at 64.1.

Specs.. (Running dedicated server on same PC i play TF2)
i7-950 (4.1ghz)
6GB DDR3 2000mhz
2x GTX280
1200W ThermalTake ToughPower
Vista Ultimate 64-bit SP2

I use a program called WinAFC which allows me to lock the CPU core(s) + Memory to specific programs. The server has 2 core @ 4.1ghz and 1GB of DDR3 RAM which is way more than whats required to run a TF2 server.

Also could someone post a partial cfg code for a 66 tick server.
I run several TF2 server's at 66 tickrate and 500fps with the following cvar's

// bandwidth rates/settings
sv_allowdownload 1
sv_allowupload 1
sv_mincmdrate 30
sv_maxcmdrate 67
sv_minupdaterate 20
sv_maxupdaterate 67
sv_minrate 10000
sv_maxrate 30000
sv_maxupdaterate 120

In the command line I have " -tickrate 66 +fps_max 650 "

Now judging by the machine specs I'm assuming you run the server off your own computer + play from the same computer. This could very well have some adverse effects on the stability of the server/fps, however it appears to be running fine beyond the fps issue.

If you want to reach 1000fps, you can try setting fps_max 0 in the command line, however you should run some form of Multimedia timer in the background, and have HPET enabled in the BIOS.

Hope that helps Smile
Mohawk Voice v1.0 now available!
[Image: 331lwzt.jpg]
Ah yes looking though my BIOS ive found HPET and enabled it including the 64-bit mode. I thought this function was only supported by server M/B and not desktop boards (Gigabyte GA-EX58 Extreme).

Thanks for the snippet of your cfg, i'll see if it improves my situation.

Thanks bhumphries the HPET worked wonders. So i dont overstress my system ive capped the fps to 500
Glad to see you got everything sorted Smile
Mohawk Voice v1.0 now available!
[Image: 331lwzt.jpg]

Forum Jump:

Users browsing this thread: 1 Guest(s)