SRCDS Steam group

What am I doing wrong...
I am having a rather stressful problem...

I am having trouble getting my server online.
I have forwarded my ports to a static ip address, which I set in the servers network configuration.
Still... nobody can join, or even see the server in the steam server list.
The server's OS is Ubuntu 9.04.
My router is Belkin Wireless N. F5D8233-4v5

I can successfully get people to join when I run the server on the computer that I play from.

I'm running out of hair to pull out. Sooo.... Please for the sake of God, Jesus, Allah, Buddha, Sheba, Chuck Norris, Megan Fox or whatever god or goddess you worship, help me.
I just can't figure out how to put an end to this time vampire.
Make sure ubuntu doesn't have any default firewalls enabled that block all incoming traffic except port 22. I know some distributions come with a firewall enabled.
Looking for a game server? Visit and pick one up as low as $2.50 / mo!
I had the same issue with linux iptables blocking the server from being seen. The command you use to open the port is below. Make sure you open all ports needed. Hope this helps

iptables -A INPUT -p udp --dport 27015 -j ACCEPT
hmm. I still can't get it working...
I guess I'll try windows on the server and see if I still get the same problem.
Thanks for your help.
A few questions just to make sure this isn't your router. Did you set the server to sv_lan 0. This makes it so your system is an internet game instead of a lan game. If this is set the issue seems to be on your router because the server is accepting connections which you can see by being able to play on your computer. I would open a range of ports because a few of them are required for other steam services. Open these ports on your router
UDP, TCP 27000-27050
UDP, TCP 1200

I would also make sure your router has the correct IP to forward and that the system is only using that IP.
Well, considering it's a dedicated server. I would think that sv_lan would be set to 0 by default.
I have had several servers working before this. I also had a different router then.
I'm not sure, check to make sure no firewalls are running, and make sure that your server is listening on port 27015... I don't use ubuntu distros, I prefer red hat my self...
Looking for a game server? Visit and pick one up as low as $2.50 / mo!

Forum Jump:

Users browsing this thread: 1 Guest(s)