SRCDS Steam group

Server not starting
Fedora Core 4
gcc 4.0.0 20050519
ldd 2.3.5
kernel 2.6.11-1.1369_FC4

I am trying to run my server on a fresh install of Fedora 4. The box is behind a router with 27015 forwarded to the box IP, and the fedora firewall and selinux is disabled. When I try starting the server with this command:

./srcds_run -console -game cstrike +ip -debug

it gives me the error:

WARNING: NNET_OpenSocket: bind: Cannot assign requested address
Couldn't allocate dedicated server UDP port
cat: No such file or directory
email debug.log to

and the debug.log just says crash at my command input. I have tried changing my ip address to the internal LAN address of, but it just hangs after

Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL

I've also tried setting the server as the DMZ in the router, but that gave the same results. If I don't assign an IP, it uses and hangs like my internal. I am really at a loss as to how to fix this. If anyone has any clue how to fix this, please let me know.
are you really anal about security on that box? if not, try adding eth0 (or whatever your nic is called) as a "trusted device"
United Strike Marine Corps
USMC-CO| θ (theta)
How would I make it trusted?
I've never done it through command line, only through desktop (startx)
United Strike Marine Corps
USMC-CO| θ (theta)
Ok, I still haven't figured this out. Has anyone else seen this problem and been able to fix it?
you cannot bind to an external ip address... thats a not possible as far as i know... just bind it to your internal adres, the steam authservers will pickup your external ip for the list Smile

Quote:hostname: Take it or leave it killing fields [01]
version : 47/ 3213 secure
tcp/ip :

thats internal, is external and shown in the server list.
To be (an admin), or not to be (an admin), that is the Question. steam linux install guide for cs 1.6
I've tried it with both internal and external, but internal makes sense. When I use the internal IP, it stops at:

Auto detecting CPU
Using AMD Optimised binary.
Auto-restarting the server on crash

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game .dll loaded for "Counter-Strike: Source"
maxplayers set to 32
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL

After this, it doesn't do anything. Any idea why?
i was having this problem also... when it hangs try typing in "map cs_office" and see if it forces the level load and then makes the config file load. honestly i dont know how i fixed it but one day it just stopped happening.

also have you run the -update switch at all?
ya you need to add a map into the command line and maxplayers
./srcds_run -game cstrike +ip +maxplayers 20 +map de_dust

otherwise it starts a server running no map and no player slots

Forum Jump:

Users browsing this thread: 1 Guest(s)