SRCDS Steam group

[resolved] Another.. server wont show up in master list problem*
server os: windows xp with sp3
processor: amd athlon x2 6000+
ram: 2gb
games: team fortress 2
bandwidth: 3mbit
router: dl-614+ with firmware 3.44
local ip of server:
external ip:
port forward screenshot:

I just can't figure out this at all and some of it seems backwords. When I use the program(gui) the port checked from an online site is being forwarded and responds correctly as working but nothing is being shown in the master list. When I use tf2 itself the server will instantly show up in the master list but for reasons I don't know.. the port wont open as the router won't detect the service so nothing gets port forwarded. I've tried using a few things on both accounts that I read but it didn't seem to help (heartbeat 2, disabling upnp). I made sure windows firewall is off and nod32's firewall is off. For those that recommend the console version of the software versus the gui version.. I don't see the difference as all it is.. is making a batch file to make the process faster compared to 2 separate projects? I've tried leaving the program on to for hours when I'm sleeping to find when I wake up nothing is still listed compared to instantly using tf2 itself. Sad I find it annoying that my router wont detect tf2 as a service or w/e to port forward when using it as a server and the fact that it even needs to detect the stuff at all. :X Remember what I said about this stuff being backwords? program- port opens but nothing listed / tf2 listed but port not being opened Big Grin
Open 27000 to 27050 TCP & UDP.

Plus port 1200 UDP / TPC.
UDP: 1200 (used for friends service)
UDP: 27000 to 27015 inclusive
TCP: 27020 to 27050 inclusive
UDP: 27015 and 27020 (default HLDS, SRCDS and HLTV port)
TCP: 27015 (SRCDS Rcon port)
So what your saying is: When you run your server, it does not show up on the master server list or on a website such as but if you join the server, it will appear on the master list? And when you exit the game the server then leaves the master list again?

There are a ton of reasons why your server might not be showing up on the master list, its a common problem that can have a number of different causes. The only thing I could recommend would be opening your router interface and make sure that anything to do with blocking WAN requests is disabled.

On my router I have "Block Anonymous Internet Requests", "Filter Multicast", "Filter Internet NAT Redirection" and "Filter IDENT(Port 113)"
all disabled while I do trouble shooting on problems such as this. I am also not sure how the GUI works, but in your server.cfg file there is a way to manually add master servers like this:

setmaster add
setmaster add
setmaster add
setmaster add

which may be worth a try.

Good luck!

[Image: 2342.jpg]

[Image: cstrike2-05.png]
Well after a lot of trial and error I finally found out that it was just my crappy router. :\ All I really needed to do was port forward 27015.. The biggest thing that was stopping me was the firewall tab settings as I guess I had some old stuff in there that I assumed got removed each time after like 10sec of putting them in there and figured it just went away and never showed up cause it didn't work rite. It turns out when my router got restarted a few times of me tinkering that I noticed those settings were still there! :0 I had like 10 different steam/tf2 ones I made and I removed all of them. It's a huge bug and hard to notice unless by luck as that stuff stopped showing to after a minute even after a router restart.. Also and never showed my server in there. I'm not sure if it takes them an hour or w/e to list them or if its pretty instant or not. One of these days I'll get a new router. XD Thanks for the help.

Forum Jump:

Users browsing this thread: 1 Guest(s)