SRCDS Steam group

counter strike source client can't see LAN server
Hi there;

My Counter Strike source client is unable to see my LAN
only server and I was hoping someone could suggest something
to try and make it work.

I precisely followed the installation instructions on the
steampowered web site.

Here is the command I am using to start the server:

./srcds_run -nomaster +sv_lan 1 -game cstrike

However, my client is unable to see the game. When I hit
refresh on the find servers -> LAN tab it says "there are no
servers running on your local network." I tcpdump shows there
is udp broadcast packets on port 27015 being received but the
server never responds.

When the server starts it says:

Auto detecting CPU
Using SSE2 Optimised binary.
Auto-restarting the server on crash

Console initialized.
Attempted to create unknown entity type event_queue_saveload_proxy!
Game .dll loaded for "Counter-Strike: Source"
maxplayers set to 32
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL

Here are the particulars on my computer:
gcc version: 3.3.3
ldd version 2.2.93
kernel: 2.4.18-14 distribution redhat 8
hardware: linux dell inspiron laptop 1.8 MHz mobile P4 with
512 meg ram.
you should try upgrading your kernel to 2.6, although I am not sure if thats the problem.
United Strike Marine Corps
USMC-CO| θ (theta)
Is this a rented server, or one you have physical access to? If its one you have access to and you have a router, try adding the internal IP address to the starting commaned line of your server. For example, my external IP is, but I have to use to get it showing correctly. HTH.
Your ldd version is 2.2? thats your glibc, glibc NEEDs to be 2.3
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
> Your ldd version is 2.2? thats your glibc, glibc NEEDs
> to be 2.3

Alas, no joy. I upgraded glibc and glibc-common to 2.3.5-10
and I have exactly the same results.

ldd --version
ldd (GNU libc) 2.3.5

A netstat -an shows something is listening to port 27105 on
both UDP and TCP.

I used the server.cfg generator utility (which is very cool,
by the way) to generate a server.cfg to see if there was
something I might have missed but that didn't help either. I
put the server.cfg file into srcds/cstrike/cfg.

One thing that is interesting, in the window that I ran the
program from I typed users it gave me this:

"Can't 'users', not running a server"

Then, if I enter

map cs_italy

then the users command shows:

0 users

In either case my client still couldn't see the LAN game.

Here is the command that I used to start the server:

./srcds_run -game cstrike -nomaster -ip +sv_lan 1 -map de_dust -console
no, try this

./srcds_run -console -game cstrike +ip +port 27015 +map de_dust +maxplayers 16

that is how it should work. If you still cant see the server, when you start the game type in your console ...


I have no idea what the -nomaster is

I dont think I read everything on what the problem was kinda half
> connect

AHA! That was the magic. Even with the all the adjustments
I made the server never showed up as LAN game but an explicit
connect through the console did the trick.

Thanks, everyone!

Forum Jump:

Users browsing this thread: 1 Guest(s)