SRCDS Steam group


sv_lan 0 not working [resolved]
#1
sv_lan 0 is in my server.cfg file, in my server command line, but it still shows up as lan. Firewall is off, ports are forwarded at 27000-27040, but it still shows up as LAN. Startup line: c:\srcds\orangebox\srcds.exe -console -game garrysmod +map rp_downtown_v2 +sv_defaultgamemode DarkRP -sv_lan 0 -autoupdate -maxplayers 30 +hostport 27016 +tv_port 27021 +clientport 27006

It worked the other day. My ports are forwarded to 192.168.1.104, but the console creates it at 192.168.1.102. I assume that is the whole problem. The other day it created it at 104 rather than 102 (ports are forwarded at 104). How do I fix this??
Reply
#2
For you, it will always show as LAN, but to others it will show as internet...
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Reply
#3
The command is -port #####.
I don't think Hostport works, but I can be wrong...
~ Mooga ...w00t? - SRCDS.com on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Reply
#4
You do not need to change the clientport also, and hostport i think only works with tf2/dods
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Reply
#5
Well I do need to change that stuff or else I get the "Couldn't allocate server IP port" error. And it did work the other day with all of those settings.

Edit: The main problem is that it uses 102 rather than 104 now, how do I fix that?
Reply
#6
Ah, needed a static IP...
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)