SRCDS Steam group

srcds.exe will not load up!
Hey all, I was just re-installing a Half-Life 2 deathmatch server through srcds as I've done many times in the past. I ran everything in the install guide as per usual, but as I go to run the command line to start the server up for the first time, it just... won't do anything! I've even tried double clicking the srcds.exe file directly and nothing. A dos window won't even pop up. No errors, etc it just doesn't do anything at all when it's run. I've tried running the program directly through dos, and nothing. The hldsupdatetool.exe works just fine, and I have no idea why srcds.exe won't. This is on Windows Server 2003. I've never seen this problem before, any advice? Thanks!
You have to create a shortcut that looks something like this:

c:\srcds\srcds.exe -console -game "hl2mp" -maxplayers 10 +map map_name

Double clicking SRCDS, as you found out, will do nothing Smile
Ohhh ok! I ran that exact line through the 'run' tab and there was nothing, but I'll try adding this line to srcds.exe directly Smile

Edit: It's still not doing anything argh!

Edit 2: I'm an idiot! I had "hl2dm" instead of "hl2mp" Toungue

*shakes head*
Did you change the directory to match yours? And the -game to match the folder name of the game? And the +map to the default map you want it to start on?
She's working great now Beaver! Now I just have to remember which specific ports to open up (as it's been a while) Wink I appreciate the help!
Open up ports 27000-27040 UDP/TCP Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)