SRCDS Steam group

[SOLVED]TF2 - Segmentation Fault (Known Solutions not Working)
Hello there. Recently I've started running a TF2 dedicated server out of my own rented box. It's nothing special, but it gets the job done fine when it runs.

The trouble is that I seem to randomly be hitting a Segmentation fault error which will repeat itself over and over on the server restart. I know this problem has actually been pretty common on Linux servers recently, but has mostly been fixed. I seem to be experiencing the problem still though.


Quote:OS: Ubuntu 9.04 (Linux Kernel 2.6.28-11-server)
RAM: 512 MB (Not stunning, but seems to work flawlessly anyway.)
CPU: Intel Dual Core 1.6 Ghz
Game: Team Fortress 2 (as mentioned)
Mods: MetaMod: Source, Sourcemod (disabling them makes no difference)

And here is the script I use for starting the server. Note a friend of mine wrote it, but it doesn't seem to matter much. Running the server directly from the shell and not through a script had the exact same results.


PARAMS='-game tf -timeout 30 -autoupdate +debuglog tf2debug.log -NoQueuedPacketThread +map cp_dustbowl +port 27015 +maxplayers 24'

starttf2 ()
nohup "$SRVBIN" "$PARAMS" >"$LOGFILE" &
echo "Started the Team Fortress 2 server."

stoptf2 ()
PID=`ps axf | grep srcds_run | grep -v grep | awk '{print $1}'`
PID2=`ps axf | grep srcds_i486 | grep -v grep | awk '{print $1}'`
kill $PID
kill $PID2
echo "Stopped the Team Fortress 2 server."

case "$1" in
    echo "Usage: ./tf2srv [ start | stop ]"

If you don't want to bother reading the whole script, the actual command run to start srcds_run is:
/home/mjcorm/tfds/tf/orangebox/srcds_run  -game tf -timeout 30 -autoupdate +debuglog tf2debug.log -NoQueuedPacketThread +map cp_dustbowl +port 27015 +maxplayers 24

Thanks in advance for any advice you can give me. It's becoming very frustrating to see no working solutions for my problem after a lot of searching. Not to mention thinking the server is finally going to run correctly only to have it randomly crash in the middle of the game.

In case you were curious, the log file doesn't say anything interesting. Merely part of the startup text follow by "Segmentation fault" and a restart.
Try running a ./steam -command update -game tf -dir /path/to/server -verify_all
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
I did as you said with somewhat interesting results.

When I ran the verification, it updated the cp_dustbowl.ain file. Dustbowl was the map that was being played when it crashed, but the ain file was fine before (I had tried file verification already).

After I verified it I started the server up again and sure it enough it worked fine for a while. I left to go do some things but apparently it crashed again during a map change.

Is it possible my server is corrupting its own files for some reason?
No, it should not, what map did it try to change to? If you are running in screen, try using a screenlog to see what is happening.
screen -L -A -m -d -S TF2 ./srcds_run etc....
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
According to logs the random map plugin picked pl_badwater. However I'm not sure if a map vote changed that during the round or not before the map change occurred. However it never logged a map change from any plugin so in all likelyhood it changed to badwater. I have to go eat dinner right now but when I get back I'll run the verification again and see if there are any .ain files that get redownloaded. (Specifically badwater's).


Well the verification didn't show up anything. It was all up to date. I started the server up again and it ran. So I joined it and changed the map several times. It's running just fine now. But I don't expect it to last. If you want to see the server yourself it's at I'll be keeping tabs to see if it shuts down in my favorites list.


Well the server crashed. This time I was in the server when it happened too. When it crashed, I was able to wander around the map for quite a long time as the map ended. I was never frozen in place for the map to change and I could just wander around without any weapons. It's pretty much the same as if my team lost (it was labeled stalemate actually) and I was walking around at the map's end. After a while of walking around which was much longer then usual, the connection warning popped up and I timed out.
Hmm, never asked, but was it 64 bit or 32
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
pengy Wrote:Hmm, never asked, but was it 64 bit or 32

32 bit actually. And for now I have the server running again, and thankfully has yet to crash throughout my play time (which was quite extensive and involved crazy mods like RTD).

I expect the server will have crashed again by tomorrow morning though. Sad
What a surprise! It's still running. I don't want to jinx myself but maybe the problem has finally gone away for a while.
And there it goes...the server crashed when I tried to join it. It always crashes at "Sending Client Info" if it happens to crash when joining.
Well, the problem seems to be solved now. I decided to make a switch to strait up Debian 5 instead of using Ubuntu Server and it seem to run smoothly so far. No crashes, hanging, or really any strange anomalies at all. Problem Solved. Wink
(07-01-2009, 09:13 AM)TheByrus Wrote:  And there it goes...the server crashed when I tried to join it. It always crashes at "Sending Client Info" if it happens to crash when joining.

I have the same problem with my server. It is running on ubuntu. Any different solution ? Sad
Please do not raise old, dead threads from the dead. If you need similar help, please feel free to post your own thread with your question. Remember to read the required READ ME FIRST thread for the area in which you are posting.

Thread Locked.

Forum Jump:

Users browsing this thread: 1 Guest(s)