SRCDS Steam group

CSS Server Crashing.
I created a CSS server a while back, everything ran fine, until I made it 100 tickrate.

All my friends can join it without a problem, but when i join it, my internet on my computer crashes, theres no error or nothing. This only happens when i join my server.

I take the 100 tickrate off back to 33. It stops.

I tried removing all the addons, same problem. So i tried reinstalling css on the server, doesn't fix it. My startup line is

./srcds_run -console -game cstrike -tickrate 100 +ip +fps_max 0 +map de_dust2


Running Ubuntu server 9.04
can you play on other tick 100 servers without a problem? maybe just your computer or internet connection cannot handle the data rate. in that case you can just reduce your cmdrate (and maybe the updaterate) of your game and keep the server running at tick 100. (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
That's what i thought too.

I can join any 100 tick server.

My computer i play on and inernet connection is really capable of doing so.

I used to run a windows server off an old p3. I had 100 tickrate on that, worked fine. Not sure why it's failing to work now.
on windows you need some "trick" to really get a tickrate of 100. maybe it was running at tick 64 only (that's the windows-"limit").

first make sure your bandwidth is set correctly in steam. maybe you should measure the real bandwidth instead of relying on what your provider says (e.g. google for dsl speed test and pick something located in your country). if you want absolutely be sure set in your cs:s config the bandwidth using the rate command (in bytes per second). keep the setting a bit below the real bandwidth, e.g. to 80% only.

if you then get choke you need to lower the cl_cmdrate and cl_updaterate settings. net_graph 3 will help you here... (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
#5 (Speedtest Report)

Yeah, i read about that windows does it, but it showed up as 100 tickrate so not sure.

I also ran a css server way way back on linux before windows and never had a problem. I'm pretty confident it has something to do with my ports.

Last night i decided to run it only as a lan, worked perfectly, not one problem. Yet when i changed it to WAN, My internet would crash. I changed the ports around (CL '27006 and 27100" and server ports "27016 and 27020') still didn't work. This is what I am not getting, why would 100 tick work only in LAN and not WAN. I take off the tickrate and put it back up for WAN, works perfectly.
Maybe your router cannot take 100 packets a second. Or thinks its a DDoS
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)