SRCDS Steam group

Port Listening problem
I'm running srcds as a CS:S server on the standard port 27015

I can connect to the game on LAN but people cannot connect via the internet. I'm positive I forwarded the port properly as I can SSH in from outside the router. However, when I run both internal and external port scans the port(27015) comes up as closed.

It seems strange that I can connect but not see the port? I don't have a firewall. When I run netstat -l srcds comes up but the tcp port is listed as hostname:27015 which seems strange because for sshd (i changed the port to 565) the service is listed as listening on *:565. Why is there a hostname specified on :27015
you cannot compare ssh with srcds. srcds uses udp, ssh tcp. make sure that you have forwarded the udp port 27015 to your server. but still, udp is a connection-less protocol and thus can make problems with NAT, it the NAT router does not understand the high-level protocol (i.e. the game protocol in this case).

netstat shows the hostname for the srcds port, because srcds binds always only one ip address. ssh binds all addresses, so netstat shows the * there. make sure (using netstat -n) that the ip address is really the one that is connected to the router. the hostname could also resolve to which would be a problem then... (Linux Kernel HOWTO!)
Do not ask technical questions via PM!

Forum Jump:

Users browsing this thread: 1 Guest(s)