SRCDS Steam group

[RESOLVED]srcds_run not starting properly
I've browsed dozens of forum threads and it's helped me understand this process much more than I did, but I still can't get my server to register with the Steam servers.

I'm running Ubuntu 8(can't remember specifically) on a pentium 4.

I followed the instructions as closely as I could, and start my serving using this command: ./srcds_run -game tf

It seems to work alright, but it stops here:

Quote:Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL

I gather, from other posts, that it's supposed to tell me that it successfully connected to the Steam servers. It also gives three errors which seemed to be normal, since it ignores them.

Quote:Particles: Missing "particles/error.pcf"

Unknown command "r_decal_cullsize"
Unknown command "startupmenu"

I can use the IP switch to specify my local IP (which changes the 127... to 192...,) but I can't use it to specify my external IP (says the socket is unable to bind to the IP.)

Based on other threads I've seen, I've tried the following switches without any luck:

-sv_lan 0
-map ctf_2fort
-port 27015

I also have my router configured to route all traffic using port 27015 to the static local IP address of my server.

I've run the steam update a few times just to make sure that I had all the necessary files.

If there's any other information I can provide that will help someone help me, let me know.
Did you try +map cft_2fort with a plus sign?
It is +map not -map
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Wow, you guys are awesome. That had it up immediately.
Added [RESOLVED] infront of this threads name.

Forum Jump:

Users browsing this thread: 1 Guest(s)