SRCDS Steam group

Cannot Connect to Server

So recently I've been trying to set up a dedicated server for me and some friends to play on.

I installed Hlds, updated it and installed the game. Everything worked great and I finished it off by adding the launch configs to the srcds shortcut and adding in a server.cfg to my cfg folder. (Not a server.cfg.txt)

Here are my launch options

D:\Servers\Left4Dead\l4d\srcds.exe -console -game left4dead +ip +hostport 27015 -+map l4d_hospital01_apartment.bsp

And this is my server.cfg.


    hostname "Whiffen's Server"


    sv_consistency 1


    sv_log_onefile 0
    sv_logbans 1
    sv_logecho 0
    sv_logfile 1
    sv_logflush 0
    sv_logsdir “Logs”


    sv_allow_lobby_connect_only 0
    sv_search_max_ping 150
    sv_lan 0
    sv_region 0


    sv_cheats 0
    sv_pausable 0

When I opened up the Scrds shortcut windows firewall poped up and I hit allow for everything.

So it started up great and people were even joining.

I then processed to install sourcemod and metamod. Both worked and the console showed no errors.

I tried to connect to my server from the same computer I am hosting it on. I get the connection failed after 10 tries error. I have already googled the error and found some posts here and I know a lot of you don't like when people try to play from the dedicated computer but I only have one PC and I can't do everything I would like from a local server.

So anyway I added "-port ###" and "-clientport ###" to the scrds lauch options in some post I found, then I found you only need "-port 27016" in it so I changed it again. Then I found out I shouldn't be putting that in the scrds launch options but in the L4D launch options.

Anyway I still got the error and then I noticed that no one could join anymore!

Then I tried to forward ports 27000 to 27050 instead of just port 27015. I used PFPortChecker to check if they had been opened correctly and they checked out.

Still same error and still no one could connect.

I am at a loss. I uninstalled source and meta mod, my launch options are back to what I posted at the beginning with no -port or -clientport.

Left my ports as they were at 27000 to 27050 and I know my IP hasn't changed. Here is a pic.

What the hell happened? I can understand if I'm still having problems connecting but why cant anyone else connect anymore >Sad

Any Ideas would be great, and I'll give you a cookie if someone can properly explain how I should go about connecting to my own dedicated server, I don't care if its not a good idea.

EDIT: Taking a look at my console I see "Server is hibernating" could this be my problem?
try disabling your firewall
Mmm, sorry I don't think that's it XD

Forum Jump:

Users browsing this thread: 1 Guest(s)