SRCDS Steam group

L4D: Servers not showing up in Xfire/Gametracker/Master list
So we have 4 L4D servers running.

We can:
  1. Connect to the servers from lobby using ms_force_dedicated command
  2. See the servers in HLSW
  3. Connect via HLSW
  4. connect via "openserverbrowser"

The problem is that we cannot:
  1. See the servers in Xfire or gamespy
  2. see the servers in the master server list
  3. see the servers listed on Gametracker
  4. ever see anyone joining them unless we are playing in them ourselves

They are always empty and they don't show up on the server listings. We plan on getting a few more up and running, as we have access to a 100Mpbs Data Center, but how can we make these show up on the server listings?

Our server.cfg is as follows....

Quote:// Server Connect Settings
hostname "ABM| Survival Hell"
rcon_password "xxxxxxx" // password to remotely connect to your server console
// sv_password ""; // password to server, leave commented out for public server
sv_lan 0 // 1 - LAN , 0 - Internet
//sv_steamgroup xxxxxx // Steam group # to assign to server
//sv_steamgroup_exclusive 0 // <1> Do not connect to the Match Making Service
sv_allow_lobby_connect_only 0 // Allow connections without creating lobby
sv_region 1 // West Coast
sv_visiblemaxplayers 4 // Visible Player Slots
mp_disable_autokick 1 // Keeps from automatically kicking players

// Server Gameplay Settings
sv_cheats 0 // 0 - Off, 1 - On

// Voice Options
sv_alltalk 1 // 0 - Off, 1 - On

setmaster add
setmaster add
setmaster add
setmaster add
setmaster add

//Versus and Coop Fix
sv_gametypes "survival"
mp_gamemode "survival"

//Lobby Connections
//sv_search_key [searchkeyhere]

Is there something we are missing in this simple config that would be causing this?

Our router has ports 27010 - 27060 all open.

The whole purpose for having these servers is to make more enjoyable west coast servers available and share the bandwidth with all. Any help would be greatly appreciated!
try taking out the setmaster commands, you dont need them anymore i thinkz.
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Took out the setmaster commands, and it still doesn't seem to be showing up. Sad

I think they need to be open for udp and tcp. Not positive.
what is port 1200 and 27005?
1200 is the old rcon port, 27005 is clientport
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
So are these the correct ports then?

(copied from an old post....)

UDP 1200
UDP 27000 - 27020
TCP 27015
TCP 27030 - 27039

Is there any others?
Half Life 2 - UDP 1200
UDP 27000-27014
TCP 27015
UDP 27015
TCP 27020-27050
UDP 27020
TCP 6003
TCP 7002
Is what i use
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Ok, everything is open...

what are 6003 and 7002 used for?
Rcon for hl1, might be needed for hl2 games
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
well, all ports are open and I still can't see the servers...

Kinda confused here as to what may be causing this. We used to have some CSS servers running on the same ip and ports and never had an issue.

Forum Jump:

Users browsing this thread: 1 Guest(s)