SRCDS Steam group

[FIXED] Server is unconnectable
Hey there. I tried:

c:\srcds\orangebox\srcds.exe -console -game garrysmod +map gm_construct -maxplayers 3

and the console launched. But, the GUI version has yet to launch at all and the server is not connectable to others. They get the error: "Invalid Steam Key Size."

Server OS: Windows XP SP3 32-bit

Processor: Single Intel Pentium 4 CPU @ 2.66Ghz

Ram: 512MB of RAM

Game: Garry's Mod.

Start Up Command: Located Above.

Admin Mods: ASSMod and EasyEngine09 Mod - I had removed these, as well. Still have the problem.

Bandwidth: About 20.39Mbps Download, or 2.54 MBps, and 5.12Mbps Uplaod, or 0.64MBps.

Router: Linksys MI424WR Verizon FiOS edition - Server = Wired connection

Local IP of Server: (Static)

External IP:

Port Forwarding Screen Shot: Here.

If you have a non-typical home network, please put a small diagram.

Verizon FiOS Network Diagram: Server --> Router --> Internet
(The Router is essentially the modem.)

Mr. Savage
Can you try a DMZ?

And can you connect to it with the internal IP?(local ip)

ps. do only post ONE thread.
I have tried the DMZ on my internal IP, yet others still can't connect- even with the internal IP. It says for them, "Connection Failed after 4 retries," when they connect through the internal IP- and they get "Invalid Steam Key Size," through connecting by the external ip.

And sorry about the doublethread. Deleted previous one.
I am also getting this problem. I would be very thankful if a solution to this is workede out.
I have found a fix for this issue.

Look at that post and it should help with Gmod dedicated servers, as it runs the Source2 Engine.

Forum Jump:

Users browsing this thread: 1 Guest(s)