SRCDS Steam group

server wont reboot automatic

i have a problem with my server becaus the server dont reboot directly if he crasht(i get first a error) .

os : windows server 2008

this is my boot config.

@echo off
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title Watchdog
echo (%time%) srcds started.
start /wait /high /AFFINITY 4 srcds.exe -console -game cstrike +map de_dust2 -maxplayers 20 +max_fps 1000 +mp_dynamicpricing 0 +hostport 27015 -tickrate 66
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

the problem is if the server crasht i get than first a window's error and if i push then on ok then he reboot but how can i change that that the server dont gif a error and reboot directly without an error? .

i hope you all can help me.

gtz hardcore
hmm i have now change the system config to

start-->run-->oobe-->enable automatic update and feedback-->manually confiure settings --> windows error reporting-->

i have change it there from

ask me about sending reports every time an error occurs.


I don't want to participate, and don't ask me again.

is this enough to fix the problem or must i do some more ?
and do i dont get any error's in window's now ?
You need to run it as a service.
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
thx for you reply but how can i run it as a service ?

Forum Jump:

Users browsing this thread: 1 Guest(s)