SRCDS Steam group

Help - TF2 server timing out all users randomly
Server OS: Windows Server 2003 32-bit
Processor: Intel Dual Core 2.80GHz
Ram: 2 GB RAM
Game(s): TF2
Start Up Command: -game tf -console +ip 69.x.x.x -port 27015 +maxplayers 30 -tvmasteronly -tickrate 66 +fps_max 300 +exec server.cfg +map cp_dustbowl
Admin Mods: None

This is a brand new blank server. Tried with no server.cfg, or the UGC league config one and both give me the same results. I have this problem on 2 machines that are setup exactly the same, so it's not a machine issue.

The game servers are ran through TCAdmin, and the cpu priority has been tried as normal, abovenormal and high giving all same results. booster running, or not running = same results.

The server will run fine for a few minutes, no lag, no spikes, everything is super smooth and then BAM, everyone gets the "connection to server lost" message at the top right, and the connection drops. During 10-15 seconds, trying to reconnect to the server won't work but then when you do connect back, the server is acting normally, just as if users had disconnected on their own.

Any ideas on to what could be causing this issue would be greatly appreciated. I have asked the data center to look into possible ip filtering rules or something along the lines but according to them, everything is good on their side =/

Thank you
Sounds like its to do with the servers files.

1. Check everything is up to date. (they should be though but worth a try)
2. Try running a server with a custom server.cfg on another map and see if they run fine.

If not report back Big Grin
PLEASE! Search before you make a thread! - How To Make A Help Thread!

Post server.cfg information, and specific information on how you are running your server!

Ensure you add REP! if they solved your problem Smile
I actually posted this solution in the wrong thread.. I resolved my issue by properly configuring TCAdmin. TF2 was set to "Source" instead of "Halflife2" which resulted in it not being able to query the server. So, it thought the server was dead after a few minutes and restarted it. Problem resolved!


Forum Jump:

Users browsing this thread: 1 Guest(s)