SRCDS Steam group

Cant Connect To TF2 Server - But Can to L4D Server

I have a VPS which is more than capable of urnning a server, I can run an L4D server and connect to it fine, however when i run a TF2 server, it loads up (??) but i get connection failed after 4 retries, the firewall is fine as it connects on l4d with the same port fine (but only ever one is running)

[root@host-95-154-197-33 orangebox]# ./srcds_run -game tf +hostport 27015 +ip +maxplayers 16
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.

Console initialized.
Game.dll loaded for "Team Fortress"
Particles: Missing 'particles/error.pcf'
maxplayers set to 16
Unknown command "r_decal_cullsize"
maxplayers set to 16
Unknown command "startupmenu"
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL

That is what i get, i vae tried using no settings, -port, etc, but it doesnt work. It is the same as my l4d launch command just the game is different.

Does anyone know what is going on?

TF2 is upto date.

After a few hours of trying to debug, turns out you have to set a map with it and it will work!
Yes. You always have to set the map. Also whats the point of censoring the ip in your startup, when its in the server log
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Hehe, honestly i did not know it was there, and i dont even know why i did it, everyone esle was so i thought i'd join the crew Toungue

Yeah, L4D defaulted to a campaign, but TF2 Didnt, so thats something new :O - Coming to tihnk of it, when i used to run a dedicated server of my windows machine for testing purposes i always set the map. - Un censored

Forum Jump:

Users browsing this thread: 1 Guest(s)