SRCDS Steam group

Linux DoD:S server stuck at sv_unlag_fixstuck please help
So this is basically what happens. I have everything installed correctly I am sure of that, I am attempting to run the server on a AMD QL-60 X2 proccessor with 3 gigs of ram and a Nvidia 8200m. Here is my server.cfg
Quote:// Set the Host Name
hostname "Lion's DoD:S Server"

// Set the rcon password
rcon_password "************"
sv_password ""

// Exec files on startup
exec banned.cfg
exec rcon.cfg // file with your rcon password

// Server Logging
log 1
sv_logbans 1
sv_rcon_minfailures 5
sv_rcon_maxfailures 10
sv_rcon_banpenalty 0 (permanent ban}
sv_rcon_minfailuretime 30

mapcycle "mapcycle.txt"
mapchangecfgfile "server.cfg"

//Pure Settings for Public Server
sv_pure 0
sv_allow_wait_command 1
sv_pure_kick_clients 0
sv_allow_color_correction 1

// general server cvars
mp_friendlyfire 1 //default 0
dod_freezecam 1
dod_friendlyfiresafezone // scalable in inches of safe zone as you run through teammates
mp_timelimit 45
decalfrequency 180
sv_accelerate 10
sv_airaccelerate 10
sv_bounce 0
sv_cheats 1
sv_client_cmdrate_difference 40
sv_client_max_interp_ratio 100
sv_client_min_interp_ratio 0
sv_consistency 1
sv_footsteps 1
sv_friction 8
sv_gravity 800
sv_maxcmdrate 101
sv_maxspeed 320
sv_maxrate 30000
sv_maxupdaterate 101
sv_mincmdrate 66
sv_minrate 10000
sv_minupdaterate 60
sv_pausable 0
sv_secure 1
sv_stopspeed 50
sv_wateraccelerate 10
sv_waterfriction 1
sv_alltalk 1
mp_falldamage 10
mp_allowspectators 1
mp_flashlight 1
mp_footsteps 1
mp_forcecamera 1
mp_forcerespawn 1

//allow in game map downloads
sv_allowupload 1
sv_allowdownload 1
sv_downloadurl ""
net_maxfilesize 200

sv_region 0 // depends on your region

// Enable/Disable LAN mode
sv_lan 0

// Contact
sv_contact "*************"

// Weapon Restrictions
mp_allowrandomclass 1
mp_limit_allies_assault 2
mp_limit_allies_mg 0
mp_limit_allies_rifleman -1
mp_limit_allies_rocket 2
mp_limit_allies_sniper 2
mp_limit_allies_support 2
mp_limit_axis_assault 2
mp_limit_axis_mg 0
mp_limit_axis_rifleman -1
mp_limit_axis_rocket 2
mp_limit_axis_sniper 2
mp_limit_axis_support 2

and here is what happens in terminal/console:
Quote:matt@ubuntu:~/srcds_1/orangebox$ ./srcds_run -console -game dod +map dod_anzio +maxplayers 16 -ip -port 27015
Auto detecting CPU
Using AMD Optimised binary.
Server will auto-restart if there is a crash.

Console initialized.
Game.dll loaded for "Day of Defeat"
Particles: Missing 'particles/error.pcf'
Particles: Missing 'particles/fire_01.pcf'
Particles: Missing 'particles/burning_fx.pcf'
maxplayers set to 16
maxplayers set to 16
Unknown command "mat_bloom_scalefactor_scalar"
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Unknown command "sv_rollangle"
Unknown command "mp_facefronttime"
Unknown command "sv_unlag_fixstuck"

and it just stops at sv_unlag_fixstuck. I let it run all night and when I woke up still no luck. Oh yeah and I am running Ubuntu, and when I tried it with the same computer on windows vista it worked fine other than the fact that I could not join with a different computer on my network for an internet game. Someone please elaborate on my situation
Try run it with:

./srcds_run -console -game dod +map dod_anzio +maxplayers 16
no luck unfortunately, same thing. thanks for the quick reply btw.

EDIT: another thing is that when i was doing the updates it would also freeze, and ultimately i would have to restart the update.
How do you update it?
the standard way on linux with hldsupdatetool

to be specific I used this tutorial.
I am gonna try deleting all the files and reinstalling. Hopefully it works this time.
Try use -verify_all in the end of the command.
no luck what I noticed is that I am getting a random ip
realchamp Wrote:Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
That's the internal IP. The other one is your external(which is the one your friends has todo a connection to).

Hmm seems weird. But do you run any plugins, mods or something else?
I put on sourcemod and metamod

EDIT: I removed both sourcemod and metamod yet it still doesnt work.
Can you try a completely re-install of your server?

Forum Jump:

Users browsing this thread: 1 Guest(s)