SRCDS Steam group

[RESOLVED] Srcds Gmod server hangs upon start
Hello all,

I have run multiple gmod servers for some time now. I am familiar with the process of installation and configuration. However i recently had a severe crash and had to format my HDD. Reinstalled a new server via hldsupdatetool, when it completed install i attempted to run the server. Upon server initiation, the server shows the third line:
Game.dll loaded for "Garry's Mod"
and then just stops. I have tried a complete reinstallation of the server, to no avail. Any help is greatly appreciated, I will supply more information as needed. Thanks in advance.

Server OS: Windows XP 64
Processor: Q6600 intel quad core
Ram: 8gb
Game(s): Garrysmod
Start Up Command: "c:\srcds\orangebox\srcds.exe" -console -autoupdate -game garrysmod -tickrate 66 -port 27017 -maxplayers 12 +map gm_flatgrass
Admin Mods: None. Game has no addons yet.
[Image: Consolefail.jpg]
c:\srcds\orangebox\srcds.exe -console -game garrysmod -tickrate 66 -maxplayers 12 +map gm_flatgrass

Try that instead.
Thanks for the reply. I just tried that command line, same result. Thank you though.
Does it even come further?

And if it doesn't, try to set another map as startup map.
When implementing the new command line, it hangs at the same spot. I have tried both maps available, yet it never reaches the loading map point. I have also tried to start the game with just the command "c:\srcds\orangebox\srcds.exe" -game garrysmod this also hangs at the same location. Thanks for the quick replies.
Hmm try give this ago:

C:\srcds\orangebox\srcds.exe -console -game garrysmod +maxplayers 10 +map gm_construct
Thanks again for the quick reply. I have tried that command also and it results in the same problem. I had initially thought that the file game.dll was missing, but after asking a friend to search his *working* server directory, he didn't have that file either.
Is this indicative of a command line problem or perhaps a corruption in the srcds? I do appreciate any and all help. Thx!
How did you update your server? Try adding -verify_all in the end of it.
Just finished updating with the -verify_all, still the same result. Sad At this point I am wondering if i should format and start from scratch again? Perhaps that's a little hasty... Any other pointers? Im open for anything at this point. Thx
I don't really think that a completely re-install would help that much actually.

But have you installed other games than GarrysMod? I know it requires another game(Counter-Strike: Source, Day of Defeat: Source or Team Fortress 2). Try install those and then try start it agian. Smile
Alright, i have finally been able to return. I did a complete format and reinstall and guess what? It works. I have no idea why, I did nothing different during this installation. I do want to thank you realchamp for your time and help. It is much appreciated.

Forum Jump:

Users browsing this thread: 1 Guest(s)