SRCDS Steam group

Nearly there :(
Second post coming up and it might be longggggggggggg, want to get as much info in to explian myself better.

1st off I must explain that that a box is being rented purely for gaming, the chap was kind enough to set up 4 servers, passworded and assigned to ports. So we I had 4 cpu's, 1 for each server. 3 dods and a Css.
With the additional IP's coming in, it was decide to boot the Css out and have all Dods.

let the story begin:
1st off I deleted all of the stuff in (we will call it server-4) server-4.
Opened putty and logged into "server-4", followed instructions from the tutorials on these forums:
mkdir srcds_l
cd srcds_l
chmod +x hldsupdatetool.bin
./steam -command update -game dods -srcds_1 .

Loads of matrixs things happened, looked at the server thro smartftp and saw the dod and orangebox folders in there, copied over a server.cfg into the cfg folder.
By rights everything is looking good but.........
When looking at the server thro Hlsw it just shows up blank ,no game, no slots, no nothing.
Tried to type this in putty:
cd orangebox (enter) then nano to assign the IP and such and got bad command.
tried these all resulting in bad command:
./srcds_run -console -game dod -autoupdate -ip ********* -port 27025 +map dod_flash +maxplayers 28 -tickrate 75 +exec server.cfg
cd srcds
I was thinking that if I could reboot that server then "things might kick in.
Sadly no, I must be missing something along the way and I have no idea what.

Any help here please, as I reackon I am close.
Thanks for looking
Moving to Linux.
~ Mooga ...w00t? - on Twitter
[Image: 76561197965445574.png]
Please do not PM me for server related help
fqdn Wrote:if you've seen the any of the matrix movies, a game server is not all that different. it runs a version of the game that handles the entire world for each client connected. that's the 2 sentence explanation.
Try -tickrate 66 or -tickrate 100 Not to familiar with dods but give it a try.
*Windows lack of output*
You: Hey, I want to run this program!
Windows: Ok.. It crashed... Now what? Give up?
*linux output helpful?*
You: ./My_program
Linux:...Failed!...oo kitties!
Have you configured a server.cfg file?
^^ Yes and have put it in the cfg folder.

Think I will have another go at installing it today.
The commands you entered, they resulted in "bad command" ? Are you sure you were in the correct folder at the time?
You didnt do the steam install correctly, it should be "./steam -command update -game dods -dir srcds_1" you didnt add the dir
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]

Forum Jump:

Users browsing this thread: 1 Guest(s)