SRCDS Steam group

restore segment prot after reloc
I was running a server, and messing around with linux at the same time when my server crashed (wasnt messing around with anything related to the server). I was forced to restart because I was unable to reboot because I was unable to connect, with my server running. After the crash, I was unable to start my server and received the following error message:
[root@snobbinn srcds]# ./srcds_run -game cstrike -console -port 27015 -autoupdat
e +exec moom1 +map de_port -debug
Auto detecting CPU
Using AMD Optimised binary.
Enabling debug mode
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 35

Checking/Installing 'Base Source Shared Models' version 3

Checking/Installing 'Base Source Shared Sounds' version 3

Checking/Installing 'Base Source Shared Materials' version 6

Checking/Installing 'Linux Source HLDS' version 41

HLDS installation up to date
Failed to open bin/ (bin/ cannot restore segment
prot after reloc: Permission denied)
cat: No such file or directory
email debug.log to
Tue Jun 21 16:54:56 GMT 2005: Server restart in 10 seconds
I checked the log, and this is what I found:
CRASH: Sun Jun 19 20:46:40 GMT 2005
Start Line: ./srcds_amd -game cstrike -console -port 27015 -autoupdate -debug +exec moom1 +map de_dust2
End of Source crash report
I tried re-downloading the whole bin folder, but with no luck. Still the same error. So I emailed linux at valvesoftware dot com, and this is what he told me:
Quote:This is a problem with FC3 and FC4 relating to the SELinux addon. A quick google for "restore segment prot after reloc" will show you the various solutions.

- Alfred
Google only gave me several solutions telling me to disable SELinux but also that it wasn't the cheapest solution.

Copying the folder to my home directory and chowning does not work...

So I would like to ask, does any one know how to help me? This is seriously getting annoying, and I dont know where to turn.
PLEEEEASE help me! Sad
ok now... third attempt! Can no one help me?
why is disabling (or evening changingto permissive) SElinux not a cheap solution? it's just a matter of changing a setting?

have you even tried this yet? or this an option that you are not willing to use?
United Strike Marine Corps
USMC-CO| θ (theta)
why even install the server as root? install it as a normal user.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
So you're saying that copying to my own directory, chowning and then starting a server as a normal user is not enough?
So.. do I really have to download srcds all over again?
are you doing chown -R someuser:users srcds_l ?
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
This will fix it, but I don't know what kind of security repercusions the command can have.
# setenforce 0

It has something to do with SELinux which I know nothing about. Study it and let us know.

Forum Jump:

Users browsing this thread: 1 Guest(s)