SRCDS Steam group

Server port incorrectly reported
Hi, I'm trying to setup a dedicated L4D server.

# cat server.cfg
hostname "myhostname"
sv_contact ""
rcon_password "my_rcon_password"
motd_enabled 0
sv_region 3
mp_disable_autokick 1
log on
sv_log_onefile 1
sv_logbans 1
sv_logecho 0
sv_allow_lobby_connect_only 0
sv_search_key "my_search_key"
sv_steamgroup 123456
sv_steamgroup_exclusive 0
I start the server with
RDTSC_FREQUENCY="2405.000000" ./srcds_run l4d -autoupdate +ip my.internet.ip.address +port 44444 +exec server.cfg

The server appears as a group server in left4dead, but when I try to connect it fails. Opening console reveals that it's trying to connect to the wrong port:
Connecting to public(my.internet.ip.address:11676)
Sending UDP connect to public IP my.internet.ip.address:11676
I tried setting up my server on different ports, but it always tries to connect on 11676, which I haven't specified anywhere and it doesn't even listen on it:
# netstat -aonp | grep srcds
tcp        0      0 my.internet.ip.address:44444*               LISTEN     16605/srcds_i486    off (0.00/0/0)
udp        0      0 my.internet.ip.address:27020*                          16605/srcds_i486    off (0.00/0/0)
udp        0      0 my.internet.ip.address:26901*                          16605/srcds_i486    off (0.00/0/0)
udp        0      0 my.internet.ip.address:44444*                          16605/srcds_i486    off (0.00/0/0)
udp        0      0 my.internet.ip.address:27005*                          16605/srcds_i486    off (0.00/0/0)
Connecting to it from console with "connect my.internet.ip.address:44444" works, connecting from lobby with "ms_force_dedicated_server my.internet.ip.address:44444" somehow worked once and then stopped working and using sv_search_key fails most likely because of this misreported port.
Where does this port come from?

Forum Jump:

Users browsing this thread: 1 Guest(s)