SRCDS Steam group

steam picking up srcds as steam program
Server OS: Windows XP Home (32-bit)
Processor: AMD Athlon 64 X2 4800+ (Brisbane) Model No. ADO4800DOBOX
Ram: ~3 (physically 4, i'm dual-booting with 64-bit linux.)
Game(s): Team Fortress 2
Start Up Command:C:\srcds\orangebox\srcds.exe -console -game tf +map ctf_2fort -maxplayers 4 -autoupdate
Admin Mods: MM 1.7.1 + SM 1.2.0

I have srcds put on my home machine to test plugins and try to replicate and possibly fix errors for my clan's server(s) and generally learn about/experiment with srcds, and up until recently, i was able to run srcds and play tf2 at the same time, on the same machine (yes, i read the thread, no, i'm not trying to run a normal server, it's purely for testing/debugging/experimental purposes.)

after a steam update (which i have a feeling is the culprit, although it was behaving this way before the update was actually applied,) when i start up srcds, it shows me as "In-Game: Team Fortress 2," meaning, i can't play tf2 and run srcds at the same time, and i can't close/restart steam unless srcds isn't running (not a huge issue, i don't run it all the time,) because it sees it as a steam program, even though i followed this tutorial to the T. I'm curious if anybody has run into this before, and if they know of a fix, or if i'll have to put srcds on a different machine to continue using it in this manner.

edit: wrote the wrong version of metamod.
the autoupdate command doesnt work with windows btw. my best guess is to try updating srcds manually
[Image: b_350x20_C5A6C3E-383F2D-D2E1B5-2E3226.png]
Click here to join.
i actually just recently added -autoupdate to it, upon giving the tutorial another review after first encountering this problem, but obviously it didn't fix the problem. i'll take it off in that case.

edit: i should also mention that i have always manually updated it up to the current version, so it is up to date.
arpinity3024 Wrote:i can't play tf2 and run srcds at the same time

I vote that Valve creates this to be a feature.
arpinity3024 Wrote:(yes, i read the thread, no, i'm not trying to run a normal server, it's purely for testing/debugging/experimental purposes.)

just incase you didn't see that part. while i appreciate your vicious support of preventing people from trying to run a full-blown server on the same machine that they play the game on, i made it perfectly clear that this was not the case with what i'm doing.

i realize that running srcds on my machine doesn't emulate the server environment entirely, but if i run a listen server, it's that much farther a cry. i'd rather run srcds somewhere on my network, preferrably where i have direct access to it, which is what i had been doing without any issue until steam started recognizing it as a steam application.

so unless you have something helpful to say, i'd appreciate keeping snarky comments to yourself, thanks.

on a side note, i just found out srcds will not start without steam running.
yeah dude you need to get your head out of your ass. i to have run a srcds server on the same computer i gammed on, for testing. without i wouldnt ever know as much as i do about running a server

look at it this way if i had to learn how to install mods using ftp i wouldnt of even bothered
[Image: b_350x20_C5A6C3E-383F2D-D2E1B5-2E3226.png]
Click here to join.
dexter610 Wrote:yeah dude you need to get your head out of your ass.

I was kidding. If you are going to be yelling stuff at people, your reputation in these forums will only go one direction.
because it won't start without steam now, i have a feeling this might have to do with running hldsupdatetool while steam is running, although i never had problems with it previously. it could also be something in an update that somehow associates steam installed on the computer and srcds during the installation, so if steam is on the same computer, it probably won't make a difference if it's running or not, it'll still tie itself in with steam.

until i can be bothered to try installing without steam running and further experiment, i've got it installed on a different machine on my network. i'll report back once i have tried installing without steam running.
i have the same problem its very annoying

Forum Jump:

Users browsing this thread: 1 Guest(s)