SRCDS Steam group

Problem with SELinux on FC3
I was running a server, and messing around with linux at the same time when my server crashed (wasnt messing around with anything related to the server). I was forced to restart because I was unable to reboot because I was unable to connect, with my server running. After the crash, I was unable to start my server and received the following error message:
[root@snobbinn srcds]# ./srcds_run -game cstrike -console -port 27015 -autoupdat
e +exec moom1 +map de_port -debug
Auto detecting CPU
Using AMD Optimised binary.
Enabling debug mode
Auto-restarting the server on crash
Updating server using Steam.
Checking bootstrapper version ...
Updating Installation
Checking/Installing 'Counter-Strike Source Shared Content' version 35

Checking/Installing 'Base Source Shared Models' version 3

Checking/Installing 'Base Source Shared Sounds' version 3

Checking/Installing 'Base Source Shared Materials' version 6

Checking/Installing 'Linux Source HLDS' version 41

HLDS installation up to date
Failed to open bin/ (bin/ cannot restore segment
prot after reloc: Permission denied)
cat: No such file or directory
email debug.log to
Tue Jun 21 16:54:56 GMT 2005: Server restart in 10 seconds
I checked the log, and this is what I found:
CRASH: Sun Jun 19 20:46:40 GMT 2005
Start Line: ./srcds_amd -game cstrike -console -port 27015 -autoupdate -debug +exec moom1 +map de_dust2
End of Source crash report
I tried re-downloading the whole bin folder, but with no luck. Still the same error. So I emailed linux at valvesoftware dot com, and this is what he told me:
Quote:This is a problem with FC3 and FC4 relating to the SELinux addon. A quick google for "restore segment prot after reloc" will show you the various solutions.

- Alfred
Google only gave me several solutions telling me to disable SELinux but also that it wasn't the cheapest solution.

So I would like to ask, does any one know how to help me? This is seriously getting annoying, and I dont know where to turn.
Do *NOT* install and run srcds as root, this is a high security risk. Install as a regular user, and run as such. That should sort your problems out. I would delete the whole dir you installed as root, create a dir in your user folder for the new one is the easiest way.
What about just chmodding chowning* the folder?
Nope, chmodding won't do anything. chown may work, but unless you know what you are doing I would just start again. SELinux is designed to stop you doing things like this, I wouldn't try and fight it.
Resistance is Futile Toungue
God damn it! Still doesn't work. Now i'm pissed.
1. Create a dedicated user for srcds. --> useradd srcds
2. Set a password for the user --> passwd srcds
3. Go to the folder which holds the srcds-folder (i.e. /usr/local) --> cd /usr/local
4. Change the ownership of the srcds folder (if it resides under /usr/local/srcds) --> chown -R srcds.srcds srcds
Oh my dear fucking god! Still doesnt work!

Ok, I created a new user, I re-downloaded counter-strike source (which wasnt easy), and I still just fucking wont work! Im thankful for all your help, but that 'cannot restore segment prot after reloc' error is REALLY becoming a pain. Is there maybe any way to disable the part of SELinux that wont give the permissions? I really dont wanna disable the firewall.

Update: Just for the fun of it, I stopped iptables, since all the solutions I have found told me so, but I STILL get the same error Sad
Ok is this a server you are renting, or is it something you have set up yourself? You gotta remember Fedora is a testing community version of Red Hat, its not the enterprise tested one they sell support for. IMHO, you would be better off scrapping it and going for something else, like Debian or Ubuntu or even Slackware (which I use). If you want to go with Slack, I will be quite happy to help you out with installing Slack (on a quick box the install will fly in about 20 mins), then providing all you need is a headless (no graphical display; just console), then you will be up and running in no time. Also, you'll have Apache there ready and waiting, fully configured with PHP and ready for per user public_html drives to offshoot your sv_urldownloads to. Just a though. One more advocacy for Slack; its the oldest surviving Linux distro, and commonly thought of as the most "Unix" like. If you really want to learn Linux, then switching to Slackware will help you do this. OK, advocacy over. The mod is going to come and lecture me about Gentoo now :-S
It's a FC3 I have set up, and keep in my BIG closet filled with lots of junk. I really dont wanna switch since I use some programs on it which require a graphical display. And if I would switch to a distro where I would skip Gnome and X, I would probably go with gentoo Smile snice i've heard such great things about it (execpt for the time required to install). If I can get a new engine from someone updating to a NASA computer for source, i'll give you a call concerning install Smile

Best wishes,
you can have a firewall without SE Linux. As a matter of fact, I believe srcds runs better without SE Linux, and have seen reccomendations for people to disble it in order to alleviate problems with srcds (and I believe hlds too)
United Strike Marine Corps
USMC-CO| θ (theta)
inc0gs Wrote:you can have a firewall without SE Linux. As a matter of fact, I believe srcds runs better without SE Linux, and have seen reccomendations for people to disble it in order to alleviate problems with srcds (and I believe hlds too)
Please, do tell Smile
disabling SELinux didn't work D:
DUDE, had the same prob with FC3! I had a power out, server was running, then it took a crap, I got lazy and didnt try to find the fix, and just reinstalled the OS. Worked fine after that. Big Grin I was having alot of power out probs, but everytime the power went out, the server was broke and I had to reinstall the OS and the CSS server. I would just change to a new distro, like CentOS, still redhat, just doesnt have there name on it Big Grin Plus, what kernel your runnin? I had that problem everytime with the 2.6 !
Found a solution! Turns out I was just too lazy to restart...

Well, Go to (with gnome) Applications > Security Settings > Security Level > Type the root password > Choose the SELinux tab > Un-choose the "Enabled" tab > Press Ok > Reboot.

Forum Jump:

Users browsing this thread: 1 Guest(s)