SRCDS Steam group

Unreasonable load with bots
So recently I was given access to a server run by a friend. I was going to use it to run a private mod called Zombie Onslaught (similar to the NotD ZombieHell in some ways). Note that this mod has run on a half dozen servers since its release, always quite stable at 30-34 bots & 16-20 players. Not one of those servers was as powerful as the current one.

I had many issues with it, cpu usage would always shoot to 99-100% and stay there nearly all of the time. To find the problem, I used the usual method of removing modifications one by one until nothing was left. I removed EventScripts, SourceMod, and everything else I had. Server ran fine. Eventually I narrowed the problem down to bots.
For some reason this server refuses to run more than 24 or so bots without massive lag spikes.


Dual 2x3.2GHz Xeons (as in a pair of dual-core cpus)
Two GB RAM (not entirely sure of specifics, high quality stuff for sure)
Some 15k SCSI HDDS
OS: CentOS 5.x
Kernel Version: 2.6.18
GCC Version: 4.1.2
GLIB Version: 2.5

So I load up a vanilla srcds. Here's the server.cfg, which is the single thing I modified.

hostname "Test"
bot_quota 24

My starter:

./srcds_run -game cstrike -secure  +map de_dust2 +ip +port 27016 +maxplayers 40

I start it and connect. I then watch the server's resource usage as a friend frags bots on my other computer. At round start, cpu usage is around 98%. For the first half of the round, it never goes below 65%, peaking at over 95.
At the end of the round when perhaps 1-2 bots are alive, it's at 16-20%.

A perfectly identical srcds runs on the 2x2.66 E6700 / 2GB RAM that I am typing this on perfectly with 34 bots under the exact same OS.

As I type this, the server is running a 34-slot (20 bot) Zombie Riot with Market, Stripper: Source, and SourceMod installed. It is running perfectly fine, even full to the limit. However, the moment I increase the bot count past roughly 24-26, it goes haywire.

Any assistance would be greatly appreciated. Please let me know if there is any more information I might have that could help.
just too much bots? bots are using much cpu, they need to calculate their actions and reactions! (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
It's a bit strange considering computers with 1/4 the power can run twice the bots isn't it?

That's my issue here.
I think you changed something in the kernel config that made it do that...
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
I changed nothing, everything was freshly installed perhaps a day before with no modifications.
So no ideas anyone?

-tickrate 33?
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Tried that at some point and tested, the difference was minimal.

Load issues were the same on 33, 66, and 100-tick settings. Always spiking to absurd levels quickly.
Hmm, older xeons or newer ones
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
Perhaps two years old, new at the time.

Forum Jump:

Users browsing this thread: 1 Guest(s)