SRCDS Steam group

Master server visible at game-tiger

Im having issues to get my server to work properly, ive been doing this for a long time and i works as a network technician, so the knowledge about how this things work is no problem. Ive forwared the correct ports for my TF2 server.

I'm recieving this error during startup...

Steamservice.cpp (275) : assertion Failed: Faield to start in-process Steam service

Then it moves on and start the server,

adding master server
adding master server

Ive even put the computer host on DMZ, so every port is open.

and forwarded....

27000-27015 tcp/udp
27020-27040 tcp/udp
and even 1200 for steam friends service.

Ive set sv_lan 0 , and i have set sv_region first i tried with 3 , for europe and then 255 for the whole world.

Ive installed the server with a bat file

HldsUpdateTool.exe -command update -game tf -dir c:\tfserverny -retry -verify_all

Ive done this twice, to get a new fresh install to get the problem to go away, i can add it on hlsw and users can connect to it but its not showing up in the masterlist for some reason....

I'm running it at vanilla, no mods or anything modified just a plain install from your hlds tool.

I start the server using
\srcds.exe -console -game tf -ip +map cp_granary -tickrate 66 +maxplayers 22 -secure +fps_max 300

When i use hlsw i can add the server, from outside and its working properly. The server won't show up in any game server listing sites, as or i dont know how long time it has to be online to be shown there, still its annyoing. I have no one to test if it works, i can only test from work with hlsw and im in the same ISP there, so that might be the reason why its working.

Its no cheap router, its a linksys wrv200 business router, and everyother port on my webbserver, vnc, etc works, so i know the router is not the failure.

Any suggestions? ive opened a ticket to steam aswell...just wanted to know if anyone had this problem already and solved it perhaps.
I have been at my familys house now, trying to connect with a ADSL connection and it works perfecly. The game shows up, and i can connect to it and play on the server, no error message what so ever.

Steamservice.cpp (275) : assertion Failed: Faield to start in-process Steam service <--- this is 100% the problem,

Anyone familiar with this error line? and how do i get around it... a fresh install with a newly downlaoded tf2 didnt help me, although i ran it vanilla....

Forum Jump:

Users browsing this thread: 1 Guest(s)