SRCDS Steam group

Can't connect to server LAN or WAN (L4D)
I've installed SRCDS on my Windows Server 2008 machine that is on my LAN at home. I want to make it a public server eventually, but I can't connect to it.

More info after code snippits.

I've tried to get all settings down to a minimum, but I'm still having problems. Here is my server.cfg:

hostname Flawds L4D Server
// Rcon Cvars
rcon_password ***** //Sets remote control password
// Server Cvars
sv_consistency 1 //Whether the server enforces file consistency for critical files
sv_contact //Contact email for server sysop
sv_visiblemaxplayers 8
sv_lan 1 //Server is a lan server ( no heartbeat, no authentication, no non-class C addresses )
sv_region 0 // Region Codes: 0 - US East coast, 1 - US West coast, 2 - South America, 3 - Europe, 4 - Asia, 5 - Australia, 6 - Middle East, 7 - Africa, 255 - world
z_difficulty Normal //this is the difficulty setting

Here is my command line parameters:

"C:\Program Files (x86)\Valve\HLServer\l4d\srcds.exe" -console -game left4dead +map l4d_vs_hospital01_apartment

And here's my console output:

10.0 fps  0/14 on map l4d_vs_hospital01_apartment
#Console initialized.
#Game.dll loaded for "L4D - Normal"
Server is hibernating
ConVarRef test_progression_loop doesn't point to an existing ConVar
Game supporting (2) split screen players
maxplayers set to 14
NET_GetBindAddresses found 'Realtek RTL8168/8111 Family PCI-E Gig
abit Ethernet NIC (NDIS 6.0)'
Network: IP, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
---- Host_NewGame ----
Compact released 131072 bytes to the backing store
Host_NewGame on map l4d_vs_hospital01_apartment
Executing dedicated server config file
Commentary: Could not find commentary data file 'maps/l4d_vs_hospital01_apartmen
Adding master server
Adding master server
Sending heartbeat to master server...
Connection to Steam servers successful.
   VAC secure mode is activated.

I've tried with LAN set to 0 and 1 with the same exact console output. Why would a server with LAN set to 1 still connect out to the master servers?

It looks like the server is running, but I just can't connect. I've tried connecting to the LAN IP, WAN IP (with ports forwarded), and via the LAN tab on the server browser...

Any insight would be appreciated!
Well, I'm an idiot. Windows Server Firewall was blocking inbound connections. I added a rule for srcds and it works fine now.
LOL. Glad you got this problem fixed.
Ryan White
Owner & CEO

Forum Jump:

Users browsing this thread: 1 Guest(s)