SRCDS Steam group

Pings on server
Hi Guys,

I'm back with another quick post.

Okay i have a server running its on a fibre optic connection and the server isn't lagging as in the box itself.

But as soon as 7 or more players out of 18 go onto the server they start to get pings of 60 to 90 for no reason.

The players complain of no lag, but the pings are very high. The server is running linux.

Is there a fix or a something i need to do?

Any help would be greatly appreciated.

Some more info may help us help you. If you could answer a few of these it would be useful I rekon.

What spec is your box?

What is your upstream and downstream bandwidth?

Do you have an intelligent firewall filter? Sometimes these get upset with masses of UDP packets and throttle them.

Have you set a max and min rate and update rate?

What is your server tick rate set to, is it the default 33?

what does the stats command say for the cpu usage and bandwidth?

Are you running any bots?

what is the ping time to your local yahoo. ( or )

Do you have QOS ( Quality of Service enabled ) on any of your routing hardware?


Thanks for your reply.

Model AMD Athlon™ 64 Processor 3400+
Chip MHz 1004.65 MHz 1 gig ram

100mbps or 1000mbps ethernet going to fibre optic connection.

No firewall

I havn't set the max or min rate

The tickrate is 66

I'm not sure how ro do that stats command thing

No bots are running

Ping to 64ms and 64ms

I don't have qos installed because its linux.

Hope this helps

Uh, linux supports QoS in the kernel(would be for linux based routers though IIRC), and it can also be enabled on most routers.

Giving us what the port is doesn't help very much. you can have 1gbps going to the router, but the actual connection can be anywhere between 1kbps and up.

stats is ran by typing stats in your srcds console.

Is this a dedicated server? from a GSP(gameserver provider) or is this from your home? if its any of the first 2, there is a firewall. if its from the first, it might not be configured properly.
[Image: userbar_wow.jpg]
starting 9/24/2006 if your problem has been solved please edit your first post and add [solved] to the begining of the title. Thanks.
Hi Cryotek,

I fixed it, put the process on a higher priority than what it was on.

That seems to have sorted it, thanks for all your replies and comments etc.


Forum Jump:

Users browsing this thread: 1 Guest(s)