SRCDS Steam group

port keeps changing...
If im testing a server via ssh with a console and it gets stuck on startup cuz i forgot to add +map cp_dustbowl or whatever and i hit crtl+z to stop it and restart it with +map the server port has changed +1 however the startup line reads 27015 still the new port will become 27016 and so on... anyone know how i can like LOCK the port?

Linux OS - CentOS5
Panel - Swiftpanel
-port 27015 +alias "port" "say port is locked"

Dunno if it works. But try it.
problem solved. type quit in console not crtl+z Toungue
Ryan Wrote:problem solved. type quit in console not crtl+z Toungue

CTRL+C would break out of it also! CTRL+Z just suspends it in the backgroup, which leaves port 27015 bound. srcds automatically increments to the next port when it detects that the default (27015) is in use.
I have the similar issue on our box. We have 4 ip's and our tf2 is on another ip then our dods but the tf2 wont let me have 27015 from a different ip. Is there something special that we need in our ip aliases?

I have 2 more servers to put on this box that are steam based. All help is appreciated.

Linux CentOS5 x86_64
run this as root to see, if (and what) process is using port 27015 on that ip:
netstat --listen --inet -p (Linux Kernel HOWTO!)
Do not ask technical questions via PM!
if you run that command and find the process how do u kill them? i tired kill -9 <num> and it says server restarting in 10 secs. then your right back where you started.
When adding the ip and port to the command line, they MUST use the -. Also, it may be helpful to add those ip's to the host route.
/sbin/route add -host ip_address dev eth0:n

As for killing the process, if your using screen, screen -x to your session name, type in quit and then a CTRL+C

Forum Jump:

Users browsing this thread: 1 Guest(s)