SRCDS Steam group

Help with TF2 server through FiOS
OK, so here goes.

I initially followed the guide at to get my sever config up and running. My copy of srcds is fully updated and working. Everything on the local end, as far as I know, is fine. My problem lies in getting other people to find it. I can connect to it fine, Steam picks it up if I use the local alias when I enter it in, and it shows up in LAN if I look in TF2. However, when I enter my external IP into Steam it shows server not responding. This is also what my friends see if they try to connect. I'm on a FiOS 15/2 connection with the actiontec MI424WR router. I've forwarded port 27015 through TCP and UDP to my server comp, which is hooked up via ethernet. Everything looks like it should be working, except that it isn't. Please help, I'm at my wits' end here. I can upload any files needed to help figure this out. Oh, and the command I use to start my server is

orangebox\srcds.exe -console -game tf +map pl_goldrush -hostport 27015 +maxplayers 10
Make sure your ports are forwarded correctly. And if you have Verizon FiOS as a ISP, you might need to call them to open up those ports Smile
Wait, I have to call them? Why? Shouldn't it have been opened when I told my router to open them?
chances are on their side they are blocking the ports even if you did pf
[Image: 3386928252.png]
That is bullshit.... I'll try calling.
OK, so I called them and apparently the ports are opened. Still no dice. Anything else I can try?
Tell us which ports you have opened.
In actiontec one, you need to forward All>27015, and on, you cant just do 27015>27015, it just doesnt work for some odd reason...
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
I would open 27010-27030, TCP/UDP, but PF'ing isn't my specialty Toungue
I have fios also. First off let me start by saying you need not call them to open ports fios only blocks 80 and 21 to prevent you from running enterprise servers on there connection cause its against the EULA. Next you need only forward the ports 27015 to your server but keep in mind you prolly already have a rule to have that same port forwarded to your local machine. The server clearly runs as its showing on your lan game. You will not be able to see or connect to it using the external IP only those outside your house can. Make sure that you forward them in the following manner. 27015--> any to your machine. Dont run DMZ and be sure you have sv_lan 0 set in your server.cfg. Also make sure you assign static IP to your server since its a seperate box.
*Windows lack of output*
You: Hey, I want to run this program!
Windows: Ok.. It crashed... Now what? Give up?
*linux output helpful?*
You: ./My_program
Linux:...Failed!...oo kitties!
After its Any--> 27015, not 27015---> Any
[Image: b_350x20_C002748-004880-FFFFFF-000000.png]
I have verizon fios and all I need to do is forward port 27015 for udp and tcp. Other than that just make sure your forwarding your port to the right internal address (the computer your servers on) and you should be good to go. I recently created a 24 slot server with the verizon fios home connection and had a full house just the other night. Fios kicks butt, everyone was getting great ping (less than 50ms) prolonging they were from the United states. People from countries over seas were getting decent ping too.. (50-150ms) depending on their location. Also make sure you don't have any crazy programs like norton or windows firewall that could potentially block the port. I just looked up port scanner on google and there is a nifty freeware utility that will scan all your ports on a designated IP to see open and closed ports.
very simple and easy to use, took me less 30 seconds to install and find my what ports I had opened or closed.

On a side note if your PC is on the same internal network as your server, your friends that try to connect to your server through the buddy list will say server not responding for them. This is because the steam friends lists saves your internal address and not your wan address. They will need the wan ip to join or find the server on the list.
Yeah me too... And the same router...
Except i Got 20/5 speed...
Don't need anything else except going into your advanced firewall settings and opening those parts to the ip of your computer in your network...

which is 4.. then open the ports to that computer
and make sure your internal pc firewall isnt blocking srcds
Thanks so much, everyone. My server is now up and running.
NO problem!

Forum Jump:

Users browsing this thread: 1 Guest(s)