SRCDS Steam group

Server was working ... now I get segfault
I'm using Ubuntu 8.04. I ran updates after I noticed this problem last night and it didn't help at all. I haven't rebooted yet but this server has a nasty habit of not coming back up and needing a manual reset so I'm waiting till tomorrow to reboot it.

Basically I already had everything installed just fine and it was running/working for TF2 for a very long time. I installed the left 4 dead demo 2 weeks go and that worked too... The last thing I did that worked was ran an update for left 4 dead and now even the ./steam command won't work. I tried a new folder, freshly downloaded hldsupdatetool.bin, rerunning hldsupdatetool, and it always returns a segfault.

root@scout:/home/hlds# ./steam -command update -game tf -dir /home/hlds -verify_all
Checking bootstrapper version ...
Segmentation fault
root@scout:/home/hlds# ls -lat ./steam ./hldsupdatetool.bin
-rwxr-xr-x 1 root root 3513408 2005-09-01 21:27 ./hldsupdatetool.bin
-rwxr-xr-x 1 root root 7822833 2005-04-07 16:04 ./steam

from /var/log/messages:

Nov 16 19:30:21 scout kernel: [1995790.359740] steam[8308]: segfault at f7caf004 rip f7e8803c rsp ffa1ad98 error 4

Forum Jump:

Users browsing this thread: 1 Guest(s)