SRCDS Steam group


LAN server not showing up in steam
#1
Hiya, i've just put together a ubuntu/XP dualboot box.

it's 7.04 ubuntu
i installed the server fine, it starts up, runs fine. i can connect to it fine using connect xxx.xxx.xxx.xxx from console
i've got sv_lan set to 1.

the only catch is - it doesn't show up anywhere in the Steam LAN server browser.
i have a vanilla ubuntu install, no additional firewalls or anything.
where it gets really strange, is when i boot into winXP and run the server from there, it works fine, shows up fine in the server browser.

i had this problem several years ago with slackware9 distro and a HLDS server, from memory a friend had to tinker with iptables.

any ideas?
Reply
#2
you probably gave the answer yourself

iptables
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#3
thanks for responding!

the only problem i have is - i have no idea about iptables. i've tried allowing udp/tcp based on this sort of format
IPTABLES -A INPUT -p ALL -i $INET_IFACE -s $INET_IP -j ACCEPT
but it hasn't had any impact.

anyone experienced with hosting LAN cs servers on ubuntu???
or know what i need to be playing with in iptables?
Reply
#4
I had the same problem, but even though the server doesn't show up, if you do a search on the server ip address from within the Favorites section and the game server should then be listed and you can add it as a fav and then connect. Not sure why the server isn't showing up but this will work.

Might be worth looking at your current firewall rules as well, just to make sure its not being blocked but I don't believe that ubuntu blocks anything by default.
Reply
#5
i've disabled all firewalls, tried oepning ports in iptables, everything.
i understand that it works by adding it to favourites list, but if i'm at a cs comp with 60 pc's, i dont want to be walking round doing that to every pc.
oh wells Sad
Reply
#6
Well I'm afraid I can't help with that cause I don't know shit about linux,

I'm sure you can find craploads of info on this on google etc (Cause even I know iptables exist!)
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#7
Try not setting the +ip in the startup command. This will force it to broadcast on UDP.
Reply
#8
Code:
iptables -F

or

Code:
sudo iptables -F
Reply
#9
Code:
iptables -t filter -I INPUT -j ACCEPT -p udp --dport 27015

Add that line to your ip tables and let us know how it went.
Reply
#10
This worked! I think this should go into a sticky as it seems to be a problem with Fedora. Thank you so much for the help. The only problem I have is that it still doesn't show under the LAN tab on Steam.
Reply
#11
vectus Wrote:This worked! I think this should go into a sticky as it seems to be a problem with Fedora. Thank you so much for the help. The only problem I have is that it still doesn't show under the LAN tab on Steam.

Use +ip 0.0.0.0 instead of not specifying it or using your local ip. I've found that helps a ton.
Reply
#12
I know this may be old, but I was having similar problems on my ubuntu linux server. Here's how I got my source games to show up on the lan tab.

I have a custom firewall I've setup for masquerading and whatever, so I wasn't to eager to completely disable it. So I came up with this command that I run that allows all udp traffic in on my internal interface.

iptables -A INPUT -i eth1 -p udp -j ACCEPT

note: for ubuntu you'll need to put sudo in front of that command for it to work.

The command I use to launch Counter Strike: Source is this:

./srcds_run -game cstrike +ip 0.0.0.0 +maxplayers 64 +map cs_italy

Apparently, the +ip 0.0.0.0 part is important to get the server to do udp broadcasts. (Thanks cereal!)

This also helps with other games and mods I run on this server, like Call of Duty 4.

HTH
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)