SRCDS Steam group


Rcon works in SRCDS console, but not in game
#1
Hey i've been having some ingame rcon issues.


you see, i set the rcon password + rcon address in both autoexec and server.cfg


so in srcds it works. when i type rcon anything no errors, says i ran the rcon

but in game i enter the rcon_password ****** right and nothing happens
so when i try a command rcon say test for example it says lost connection with rcon server (UNKNOWN ERROR) yes.....so i donno what to do.

none of my mani rcon commands work either



EDITTTTTTTTTTTT


PORTS 27015 ARE OPEN ON BOTH TCP AND UDP










HERS MY SERVER.CFG



Code:
// server name
hostname "100TICK|WARCRAFT3|ZOMBIE MOD|UNLI.AMMO"

mp_friendlyfire "0"

mp_timelimit "20"

mp_falldamage "1"

sv_allowupload "1"

sv_allowdownload "1"

mp_freezetime "3"

sv_alltalk "0"

mp_limitteams "1"

sv_rcon_banpenalty "20"

sv_rcon_maxfailures 10

mp_autoteambalance "0"

mp_allowspectators ""

mp_tkpunish ""

mp_roundtime "7"

mp_c4timer "50"

mp_startmoney "800"

rcon_password *********** (pass is ther.)

rcon_address 68.43.200.179

mp_flashlight "1"

fog_enable 0

log "1"

sv_gravity "700"

sv_footsteps "1"

sv_cheats "0"

sv_customizations 1

sv_password ""

sv_spectator_password ""

mp_buytime 7

sv_airaccelerate 10

mp_winlimit 0

phys_pushscale 5      // make it more difficult for players to block doorways

bot_add
bot_quota 6
bot_quota_mode fill
bot_difficulty 1
bot_chatter minimal
bot_auto_follow 0
bot_auto_vacate 1
bot_join_after_player 1
bot_defer_to_human 1
bot_prefix "Slave "
bot_allow_rogues 0
bot_walk 0
bot_join_team any
bot_eco_limit 500
bot_allow_grenades 1
bot_all_weapons
bot_allow_grenades 1
bot_allow_pistols 1
bot_allow_sub_machine_guns 1
bot_allow_shotguns 1
bot_allow_rifles 1
bot_allow_snipers 1
bot_allow_machine_guns 1

exec banned_user.cfg
exec votebot.cfg
exec fakeclients.cfg
exec mani_server.cfg
[Image: 68.43.200.179:27015.png]
Reply
#2
Is the game rcon_address set correctly?

also what mani version and type are you using?
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#3
Drocona Wrote:Is the game rcon_address set correctly?

also what mani version and type are you using?



i set rcon_address to my wan

(im on a router)

i've tried with my LAN ip too.



in my mani_server it says :

// *****************************************************************************
// Plugin : Mani Admin Plugin
//
// Filename : mani_server.cfg
//
// Last updated : 03/12/2006


i dono wat exact version it is
[Image: 68.43.200.179:27015.png]
Reply
#4
Dizzybro Wrote:PORTS 27015 ARE OPEN ON BOTH TCP AND UDP

Are they open in both the router and firewall on the server?
Reply
#5
skeletor Wrote:
Dizzybro Wrote:PORTS 27015 ARE OPEN ON BOTH TCP AND UDP

Are they open in both the router and firewall on the server?



yes.

i have them open on my router, and my firewall has scrds allowed thru all ports
[Image: 68.43.200.179:27015.png]
Reply
#6
BUMP.....solution plsssssssssssss
[Image: 68.43.200.179:27015.png]
Reply
#7
Well I'm not sure on what to say anymore...

It's one of those things that's incorrect, bocked or unavailable..
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#8
Trust me on this one, disable windows firewall on the server.
Reply
#9
Dizzybro Wrote:yes.

i have them open on my router, and my firewall has scrds allowed thru all ports

ok, with the windows firewall that won't be enough. you have to actually open port 27015 tcp, and then a second for udp. To see if thats the issue, dissable windows firewall, and see if rcon works. if it does then you must open them ports.
Reply
#10
skeletor Wrote:
Dizzybro Wrote:yes.

i have them open on my router, and my firewall has scrds allowed thru all ports

ok, with the windows firewall that won't be enough. you have to actually open port 27015 tcp, and then a second for udp. To see if thats the issue, dissable windows firewall, and see if rcon works. if it does then you must open them ports.





who said i was using cruddy windows firewall? i use the eset beta 2. i have also tried disabling it, to no prevail also.


and my router IS also open too. as it is set to 27015 on BOTH, and i show up on canyouseeme.org
[Image: 68.43.200.179:27015.png]
Reply
#11
you use a beta firewall? That just sounds bad. If you run another firewall make sure the windows firewall is disabled. Running 2 firewalls will mess stuff up. Some people install another firewall and think windows just disables itself, and this is not the case.

There isn't much wrong with windows firewall though! You just have to know how to use it. Big Grin
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)