SRCDS Steam group


Hidden Dedicated Server
#1
dont know if im putting this in the right place, sorry if i aint,
Having trouble running my dedicated server for Hidden Beta 3.
it runs but no one can connect to it over the internet, it only seems to let people connet over lan. ill give you as much info as i can.

Connection to Steam servers successful.
VAC secure mode disabled.
Adding master server 68.142.72.250:27011
Adding master server 69.28.151.162:27011
] sv_lan
"sv_lan" = "0"
- Server is a lan server ( no heartbeat, no authentication, no non-class C addresses )

] status
hostname: Hidden : Source Beta 3
version : 1.0.1.0/7 2761 insecure
udp/ip : 192.168.1.2:27017
map : hdn_executive at: 0 x, 0 y, 0 z
players : 0 (8 max)

# userid name uniqueid connected ping loss state ad

I got these from the dedicated server console. using commands status and sv_lan, to check if i have got lan enabled
ill also post some pictures to see if that helps aswell.
Also i cant launch srcds.exe by double clicking on it i can only launch it sucessfully by loadings CMD and running the command srcds.exe -hidden
this then successfully loads the GUI menu
Thanks
Dave

.jpg   screeny.JPG (Size: 55.58 KB / Downloads: 18)
.jpg   screeny2.JPG (Size: 36.41 KB / Downloads: 17)
Reply
#2
looks like a port/router problem, please check if you have forwarded all the standard SRCDS ports to make it available to the internet
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#3
Thanks for the reply, what are the standard ports id need to forward, ive done both 27016 and 27017 which i have set to my router to my lan ip, is there anymore im missing?
thanks for help
eQu
Reply
#4
These ports:

27000-27020 UDP
27030-27039 TCP
1200 UDP
27015-27016 TCP


Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#5
Thanks for tht info, still having a few problems pinging the server once it running through my HLSW
ill post some screenys just to show what im seeing.



.jpg   screeny3.JPG (Size: 73.91 KB / Downloads: 17)
.jpg   screeny4.JPG (Size: 53.06 KB / Downloads: 11)

in the pic u can see the ports ive applied and the other pic is me tryin to see if i can see my server in HLSW, is it right that i type in my IP and the port i have nominated for the hidden server?

cheers for all the help so far!
eQu
Reply
#6
I never used routers myself, I can't help much more here becuase i simply dont have the knowledge for routing stuff.

If someone else can please take over from me here Toungue
Join the Source Dedicated Server Support Group on Steam Community!
Source Dedicated Server (SRCDS)
Free to join, Live support! (When available)

http://forums.srcds.com/viewtopic/5114
Reply
#7
Thanks alot for you help, if someone else can give me some adivce aswell id apreciate it!
eQu
Reply
#8
In HLSW just do your LAN address. I tried my external before and it didnt work.


Jackal

Reply
#9
Thanks for the reply, my LAN address does work and it show my server up fine, but im struggling to get people over the net to connect to my server, i used my other ip address to test the server to save me bugging people to test it for me, does that mean it cant be tested like ive been doing it over HLSW?
Cheers
eQu
Reply
#10
you beauties!!!! its working
cheers for all your help u 2!!!
Big GrinBig GrinBig GrinBig Grin
you make me a happy man!!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)