SRCDS Steam group


Can't connect to my own server, anyone else can
#1
I can't connect to my own server, but anyone outside the lan can.
Anyone got a clue what's wrong?
My local IP is the same as the External IP.
It's on an other computer. When I start one on my computer, I and everyone else can connect.
Reply
#2
Try to connect the same way the others do: using your external IP.

(10-28-2010, 03:40 AM)DLeD Wrote:  My local IP is the same as the External IP.
It's on an other computer. When I start one on my computer, I and everyone else can connect.

That is not possible. You have more than one computer, so you have multiple local addresses.
Warning Level: 0%
Reply
#3
on whatismyip.com I get the same ip as the local IP. And tryed to use the same way as the others, but it wont work.
When im running a server on the computer I game on, the lan ip is the same as the IP the others connects to --> Isn't the local IP the same as the external Ip?
Reply
#4
start->cmd->ipconfig /all is?
Warning Level: 0%
Reply
#5
Sounds like you just have your cable modem plugged directly into your PC.
In which your case, it's very simple, no NAT fowarding... Goodie Big Grin
Downside is you're highly susceptible to hacking if you don't have a good firewall.


If you want to connect to a game server hosted on the same computer that you're playing. Try this:
connect localhost
or
connect 127.0.0.1
If that doesn't work then you need to set your -ip startup command to 0.0.0.0 and then try the above again.
SO technically in your case your local IP is 127.0.0.1 ( localhost )
Looking for a game server? Visit fullfrag.com and pick one up as low as $2.50 / mo!
Reply
#6
No, its connected to a DHCP server I don't have any access to. Got two lines in, whit my gaming computer and my other stuff on, and the server on the other line. Seems od why I can't connect to the server unless its set up as a lan server.
Reply
#7
Odd... I'm quite confused by your network... If you want to draw it out for me in paint, that would be wonders.
Looking for a game server? Visit fullfrag.com and pick one up as low as $2.50 / mo!
Reply
#8
Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . : uio.no
Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ether
net Controller #2
Physical Address. . . . . . . . . : 00-26-18-F8-9A-2B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f1ce:8183:9909:1395%12(Preferred)
IPv4 Address. . . . . . . . . . . : 193.157.251.82(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 28. oktober 2010 21:40:53
Lease Expires . . . . . . . . . . : 29. oktober 2010 09:40:52
Default Gateway . . . . . . . . . : 193.157.251.1
DHCP Server . . . . . . . . . . . : 129.240.12.248
DHCPv6 IAID . . . . . . . . . . . : 301999640
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-B5-20-89-00-26-18-F8-9A-2C

DNS Servers . . . . . . . . . . . : 129.240.2.40
129.240.2.3
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ether
net Controller
Physical Address. . . . . . . . . : 00-26-18-F8-9A-2C
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.uio.no:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : uio.no
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Reusable Microsoft 6To4 Adapter:

Connection-specific DNS Suffix . : uio.no
Description . . . . . . . . . . . : Microsoft 6to4 Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2002:c19d:fb52::c19d:fb52(Preferred)
Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
DNS Servers . . . . . . . . . . . : 129.240.2.40
129.240.2.3
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter 6TO4 Adapter:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{FF3FE941-E383-40AB-B8F6-917979D6196F}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:103c:6fd:3e62:4ad(Prefer
red)
Link-local IPv6 Address . . . . . : fe80::103c:6fd:3e62:4ad%16(Preferred)
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{AF75EC7C-ED29-4063-A46B-13CA0CA31720}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Reply
#9
I kinda have the same problem as OP so I'm just gonna bump this thread with a similar question.

I just got my server up and running and people are able to join, however, I can no longer join my own server; it fails after 4 attempts.

I tried 'connect localhost' in console, but I still fail. I used to be able to connect to the server when other people couldn't now it's the other way around, any idea on what's going on?



::EDIT::

Nevermind, fixed my own problems once again. Just took out my IP from the srcds.exe shortcut.
Reply
#10
Seems pretty strange, whats the IP-address of your server? I can see (from your output) that your IP-adress is external, so there shouldn't be any problems with port forwarding.

I guess that you have been assigned 2 dynamic IP-adresses, which is normally (here in Denmark). Its wierd why you can't establish connection between those pc's.

Could you do me a favor?

If yes:

Slå den med jeres fiberforbindelser...

[Image: 1308107839.png]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)